Cannot delete executions with filters

I can only delete like 10 executions, that is loaded on the page.
I cannot delete executions by this filter:

the error is following:

Problem deleting executions

Property “startedAfter” was not found in “ExecutionEntity”. Make sure your query is correct.

But I have only 2770 in total executions without filters, which means the filters are not working.

Information on your n8n setup

  • **n8n version:0.230.3
  • **Database (default: SQLite):postgreSQL
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):main
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):pm2
  • **Operating system:ubuntu 22.04

Hi @inbsp, I’m very sorry to hear you’re having trouble.

In a first step, can you try upgrading to a more recent version of n8n here? I just tried deleting a bunch of old executions on my own instance running [email protected] with a PostgreSQL database while having the Execution start filter set, this worked as it should.

Hi, @MutedJam
Finally got an opportunity to stop working process and update my n8n instance to 0.233.1.
But the problem persisted. Filters properly showing the results, but when I’m trying to select filtered executions, I can only select ALL the executions.

Hi @inbsp, I am so sorry for this. I’ve tried reproducing this once again using a fresh instance connected to a PostgeSQL database. This was my exact docker compose setup:

    image: postgres:15
    restart: unless-stopped
      - POSTGRES_USER=n8n
      - POSTGRES_DB=n8n
      - ./db_data:/var/lib/postgresql/data
      - 5432:5432
      test: ['CMD-SHELL', 'pg_isready -h localhost -U n8n -d n8n']
      interval: 5s
      timeout: 5s
      retries: 10
    image: n8nio/n8n:0.233.1
    restart: unless-stopped
      - DB_TYPE=postgresdb
      - DB_POSTGRESDB_HOST=postgres
      - 5678:5678
      - ./n8n_data:/home/node/.n8n
        condition: service_healthy

I’ve then tried reproducing the problem like below:

  1. Producing at least 21 executions
  2. Heading to http://localhost:5678/executions and filter the executions using the “Execution start” filters
  3. Selecting all visible executions by clicking the Checkbox next to “Name”
  4. Selecting all executions by clicking the Checkbox next to “Select all n finished executions”
  5. Clicking “Delete” and confirm the deletion

I did however not hit any error along the way. I wonder if this could be a problem with the data in your db, perhaps caused by an incomplete migration. Can you try manually clearing older executions by running a query like this (using a suitable WHERE clause if you need to keep some executions):

DELETE FROM execution_entity;

And confirm if the problem still persists for newer executions on your side? As with all database manipulations you might want to take a backup beforehand, just in case.

Thanks for answer @MutedJam
I will try manual cleaning, but I can only do so on friday.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.