Cannot interact with Supabase API

Hi n8n team,

I am unable to interact with my Supabase DB with the Supabase API. I have set up my credentials as the docs describe, and receive a ‘connection successful’ message. After creating the Supabase node, I can see all my schemas in node editor, so a successful connection has definitely been established, however, all Get, GetMany, Create, Update etc… actions fail with the following error message.

It is worth mentioning I have changed no access settings in Supabase. I have tried with RLS off, and on with an all-access policy.

Error:
Forbidden - perhaps check your credentials?
permission denied for schema public
NodeApiError: Forbidden - perhaps check your credentials?
at Object.supabaseApiRequest (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Supabase/GenericFunctions.js:27:15)
at processTicksAndRejections (node:internal/process/task_queues:95:5)
at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Supabase/Supabase.node.js:196:32)
at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:724:19)
at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:660:53
at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:1062:20

My workspace:
Manal trigger → Supabase node (sorry the server is off now).

No output was returned.

Any help would be greatly appreciated. Thank you.

Information on your n8n setup

  • n8n version: 1.33.1
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker Compose
  • Operating system:: Ubuntu 23.10

Hey @David_Parkinson,

Welcome to the community :cake:

That error is Supabase saying that the account you are authenticating with doesn’t have access to the public schema. You may need to check that the API is allowed access to it for it to work.