Cannot run n8n on FreeBSD

Hello,

Since version 0.116.0 I cannot run n8n on my hosting with FreeBSD OS.

I install n8n using npm install n8n -g command (there is no other way on my hosting) and when trying to run n8n command I get error:

TypeError: Can not find node binding files from @node-rs/bcrypt-freebsd-x64 and /usr/home/pavvel/.npm-global/lib/node_modules/n8n/node_modules/@node-rs/bcrypt/bcrypt.freebsd-x64.node

I thought it was a problem with some limitations on my hosting but I run FreeBSD 12.2-RELEASE on VM and I get the exact same thing just with more warnings during the installation about skipping optional bcrypt dependencies (please see the screenshot from my VM).

Versions 0.115.0. and below work fine.

Thanks in advance for your support.

yes, in 0.116.0 we Changed bcrypt library from "bcryptjs" to "@node-rs/bcrypt".

However, have no clue why that is happening. I checked the library’s main page and found the support matrix below. Is it possible that FreeBSD it’s no supported? Not sure in which Linux category FreeBSD falls.

Wow, considering how many problem that change caused will I roll it back and will release the next version again with the previous library.

n8n uses now again bcryptjs:

So problem should be solved with the next release.

@RicardoE105 Unfortunately I have no idea in which category is FreeBSD.
@jan Thank you. Waiting for release.

Will update here once it is ready.

Got released with [email protected]