Can't activate workflow with Mailchimp trigger, "Unknown Error"

Describe the issue/error/question

When I create a flow that has a Mailchimp trigger, everything works perfectly when executing the workflow, but when I try to activate it, I receive an error message that says “Workflow could not be activate: UNKNOWN ERROR - check the detailed error for more information.” This happens even if the Mailchimp trigger node is the only node in the flow, so it’s not an issue with a different node. I’ve tried connecting to Mailchimp with both API and OAuth2, same result for both.

Interestingly, in a fresh workflow with a Mailchimp trigger I was able to activate it temporarily by creating the trigger node and immediately activating it without ever using “executing workflow” or testing it in any way. However, once I did run execute workflow to run some data through to help me build the rest of the flow, it refused to save and then deactivated itself and I was right back at square one.

I’ve seen this error discussed elsewhere on the n8n forums and on Github, but not recently and not for any n8n Cloud users. Any ideas?

What is the error message (if any)?

“Workflow could not be activate: UNKNOWN ERROR - check the detailed error for more information.”

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.211.1
  • Database you’re using (default: SQLite): N8n Cloud
  • Running n8n with the execution process [own(default), main]: ?
  • Running n8n via [Docker, npm,, desktop app]:

Hey @vsctech,

I will give this one a go and see if I can reproduce it.

Hi @vsctech, welcome to the community. I also tried reproducing your issue but could not import the workflow you copied above. Would you mind adding it again, maybe wrapped in code? That would help me a lot :slight_smile:

Hi @Niklas_Hatje, sure thing! Let me give that another go. (This is with it set to OAuth2, but I get the same issue if I connect to MailChimp with regular API.)

Also just to note, I updated my instance from 0.211.1 to 0.213.0 yesterday, same issue still persists on any flow I try with a MailChimp trigger.

Thanks for looking into this!

ETA: I see in the embedded post there’s a 404 error on my mailchimp trigger, which is not the case within my actual workflow. Screenshot of what it looks like on my end when I go to edit the workflow:


Hey @vsctech, thanks for the additional input. I just tried to reproduce your issue and was not able to. But I have an idea what it might be: Did you maybe duplicate the mailchimp trigger from somewhere (e.g. by duplicating a workflow or by duplicating it in the canvas)?

If you happen to have multiple Mailchimp triggers across Worfklows, try to open the Webhook URLs section and make sure that the URL is unique everywhere.

Normally, duplicating the trigger should always automatically result in a different URL and when I tried duplicating mine, it did that. But maybe it didn’t work for you somehow…

Oh, very interesting! I believe the one I posted is a fresh workflow but I’ve been duplicating so many workflows to troubleshoot this that I’ve honestly lost track. Let me do some cleanup and check my Webhook URLs and I’ll report back on what I find.

Hi @Niklas_Hatje, unfortunately still getting the error. I cleaned up my workflows so I have only two workflows that use the MailChimp trigger (my original workflow, and a brand new one I created just for testing.) As before, the brand new one worked fine and was able to activate until I used the Execute Node button and externally triggered it (by subscribing to the mailing list.) Then it’s back to not activating and giving the error. Here’s my Webhook URLs:

@vsctech We’ve deployed a fix to your n8n instance.
Can you please try activating the workflow again?

Hi @netroy, I just tried again. Sadly still no luck. I tested on the two existing workflows I’ve been using and on a new one I just created, unable to activate any of them. Thank you for your continued troubleshooting with this!

Are your getting any new errors when trying to activate these workflows now?

No, still the same Unknown Error as before:


Looks like I deployed the 0.213.0 image instead of the custom image earlier.
The correct docker image is now deployed.
Can you try activating one more time please?

Hi @Netroy, that seems to have fixed it! I’m now able to successfully activate both of the MailChimp trigger flows I created for testing purposes. I still can’t activate my original Mailchimp trigger flow, but it’s now giving me a different error message:


I’m going to try rebuilding that one from scratch in a fresh workflow, I’ll report back on how that goes. Thank you so much for all your help and troubleshooting, I appreciate it so much!

1 Like

Rebuilding my more complicated MailChimp workflow in a fresh workflow worked perfectly. I’m able to test and activate now without any errors. Thank you so much!


Got released with [email protected]

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.