Can't activate workflow

Describe the issue/error/question

I can’t activate my (small) Pipedrive workflow due to an “unknown error”. This workflow worked a few days ago when I was still testing after deploying the N8N CE on Digitalocean. But now that we want to activate it again, I’m getting this error.

What is the error message (if any)?


Please share the workflow

Information on your n8n setup

  • n8n version: 0.218.0
  • Database you’re using (default: SQLite): postgres
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm,, desktop app]: DigitalOcean (docker)

Hey @nocturnae,

Welcome to the community :cake:

If you check the webhook url in the Pipedrive node is it currently set to localhost or is it using a proper domain / IP address?

Hey Jon,

Thanks for the quick reply.

The webhook is currently on a domain like this: https://n8n-a**********
(*** is redacted for privacy)

Hey @nocturnae,

That looks like it should be fine, I can’t think of anything else that might result in that error. Does Pipedrive already have a webhook registered for that URL maybe? I know sometimes our delete doesn’t always work as expected.

It could be worth adding a new Pipedrive node to the workflow and seeing if that works.

Hey @jon,

I tried recreating the Pipedrive trigger. But that didn’t fix it. Rebuild the workflow in a new workflow, but same issue.

The only way I could get it to work, was by recreating my Pipedrive credentials (with the exact same API key).

I then worked for a few runs, but now I’m starting to see the same behavior. again.

In the current run, I have 3 executions “stuck”:

If I try to stop any of them (from within the executions tab of the workflow), I get the error that the execution ID could not be found:
I can however, delete them from the “All executions” menu. :man_shrugging:

If I try to run the workflow now manually, I get a similar error like yesterday:

When I go and check my credentials (to do the same as I did yesterday, I get this error):

It seems like something is bugging out here, and I can’t seem to pinpoint it :frowning:

I have seen that encryption error before, You mentioned using docker on Digital Ocean is that in a droplet or some other method and has it been restarted recently?

I’ve installed it using this: GitHub - johnkraczek/n8n-app-do

Hey @nocturnae,

So that looks like it uses Digital Ocean apps and doesn’t have any storage with it which is required to hold the encryption key so what will happen is if you restart n8n a new key is generated and your credentials will no longer be valid.

You will need to set an env option for the encryption key, When creating the app and it mentions environment options add N8N_ENCRYPTION_KEY and set a value that you keep in a password manager somewhere and that will tell n8n to always use that key.

I suspect in your case what has happened is either an update of n8n at some point, a planned restart or the app crashed and restarted.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.