Can't edit list price with Zoho connector

Hello guys,

I have a new problem with the Zoho Connector “Create/Update Sales Order”.
I successfully create a sales order and all the fields I wanted except the List Price field.
Whenever I add it in that node, it bugs.

How I set it up is that I just add “List Price” field in the node, put the exact same input that the one I have in “Unit Price” (which does not bug).

I get this error :

ERROR: The Zoho API returned an error.
[ { “code”: “INVALID_DATA”, “details”: { “expected_data_type”: “double”, “api_name”: “list_price”, “index”: 0, “parent_api_name”: “Product_Details” }, “message”: “invalid data”, “status”: “error” } ]

So I can’t understand why it won’t work.
Any idea ?

You’ll find the workflow below, I just removed the List Price so it would continue runnning.

Thanks guys for your help !

Information on your n8n setup

  • n8n version: 1.7.1
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): cloud
  • Operating system: mac

Hey @Damien_Busch,

I thought I fixed that in 1.7.0, Can you try changing your list price to include .00 at the end and see if that helps?

Hi Jon !

It look like it does not work except if I did it wrong (just added “.00” after my formula, the output seems ok)

Hey @Damien_Busch,

What is the data type of the price field? If you try replacing the expression with just {{ 75 }} does that work?

Yes it does work when I hard set up the value to 75.
I retry using parseInt and it works as well.
Thanks for this, I was surprised it was working for “Unit price” but not for “List Price”

Hey @Damien_Busch,

Yeah that is a bit odd, I wonder if Zogo doesn’t care as much about the Unit Price field. I think your solution is worth marking though so others know that it needs to be a number not a string.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.