Cant see node in my local instance

I have been following tutorials on creatin a custom but i keep not seeing my node in my local instance i have link it just like from the turorial but its not in my local instance

@Jon
can you help over here :sos:

Hi @Onlypfachi :wave:

This comment on Github might have some answers for you: example nodes won't show up · Issue #42 · n8n-io/n8n-nodes-starter · GitHub

You might not be following the exact same approach as in our tutorial. This can happen if you aren’t using/creating the ~/.n8n/custom folder and running npm link in there.

Two questions for you:

  • Are you using our n8n-nodes-starter project?
  • Can you see the Example Node or HTTP Bin Node that should already be inside the n8n-nodes-starter project? Is it only your node that is missing?

With all that information, someone like @marcus might be able to help you out if this doesn’t fix that up :+1:

1 Like

should i complete the custom dir innit or i cancel and run npm link

I cnt even find exaple node in thre

Can you share the exact commands you ran and the directories you ran them in?

1 Like
Initializing n8n process
Error loading node "runtime-blob-types" from: "C:/Users/Dell/.n8n/custom/node_modules/n8n-nodes-crypted/node_modules/@aws-sdk/types/dist-cjs/blob/runtime-blob-types.node.js" - blob is not defined
evalmachine.<anonymous>:1
new (require('C:/Users/Dell/.n8n/custom/node_modules/n8n-nodes-crypted/node_modules/@aws-sdk/types/dist-cjs/blob/runtime-blob-types.node.js').runtime-blob-types)()
                                                                                                                                                      ^

ReferenceError: blob is not defined
    at evalmachine.<anonymous>:1:151
    at Script.runInContext (node:vm:135:12)
    at loadClassInIsolation (C:\Users\Dell\AppData\Roaming\npm\node_modules\n8n\node_modules\n8n-core\src\ClassLoader.ts:9:16)
    at CustomDirectoryLoader.loadNodeFromFile (C:\Users\Dell\AppData\Roaming\npm\node_modules\n8n\node_modules\n8n-core\src\DirectoryLoader.ts:75:35)
    at CustomDirectoryLoader.loadAll (C:\Users\Dell\AppData\Roaming\npm\node_modules\n8n\node_modules\n8n-core\src\DirectoryLoader.ts:288:10)
    at LoadNodesAndCredentials.runDirectoryLoader (C:\Users\Dell\AppData\Roaming\npm\node_modules\n8n\src\LoadNodesAndCredentials.ts:248:3)
    at LoadNodesAndCredentials.loadNodesFromCustomDirectories (C:\Users\Dell\AppData\Roaming\npm\node_modules\n8n\src\LoadNodesAndCredentials.ts:170:4)
    at LoadNodesAndCredentials.init (C:\Users\Dell\AppData\Roaming\npm\node_modules\n8n\src\LoadNodesAndCredentials.ts:89:3)
    at Start.init (C:\Users\Dell\AppData\Roaming\npm\node_modules\n8n\src\commands\BaseCommand.ts:53:3)
    at Start.init (C:\Users\Dell\AppData\Roaming\npm\node_modules\n8n\src\commands\start.ts:213:3)
Error: Exiting due to an error.
ReferenceError: blob is not defined

i keep gettng this

Hey @Onlypfachi,

I would start by deleting the contents of your .n8n/custom folder, Once you have done that can you download the starter repo locally. Update the package name to something like n8n-nodes-test then run the command below and let me know what the outcome is. This will help us work out if the issue is with your node or something else.

npm install
npm run build
npm link
cd C:/Users/Dell/.n8n/custom
npm link n8n-nodes-test
n8n start

Hi @Jon
I have run the the all those commands but i cnt see any nodes no httpbin or example node in my local this is the complete log and commands

Microsoft Windows [Version 10.0.22621.2428]
(c) Microsoft Corporation. All rights reserved.

C:\xampp\htdocs>git clone https://github.com/onlypfachi/n8n-nodes-test.git
Cloning into 'n8n-nodes-test'...
remote: Enumerating objects: 31, done.
remote: Counting objects: 100% (31/31), done.
remote: Compressing objects: 100% (27/27), done.
Receiving objects: 100% (31/31), 134.42 KiB | 235.00 KiB/s, done. Total 31 (delta 0), reused 20 (delta 0), pack-reused

C:\xampp\htdocs>cd n8n-nodes-test

C:\xampp\htdocs\n8n-nodes-test>npm install
npm WARN deprecated [email protected]: See https://github.com/lydell/source-map-url#deprecated
npm WARN deprecated [email protected]: request-promise-native has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142
npm WARN deprecated [email protected]: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated [email protected]: this library is no longer supported
npm WARN deprecated [email protected]: See https://github.com/lydell/source-map-resolve#deprecated
npm WARN deprecated [email protected]: Chokidar 2 does not receive security updates since 2019. Upgrade to chokidar 3 with 15x fewer dependencies
npm WARN deprecated [email protected]: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated [email protected]: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142
[##################] | reify:typescript: timing reifyNode:node_modules/lodash Completed in 7481ms

added 612 packages, and audited 613 packages in 18s

49 packages are looking for funding
  run `npm fund` for details

22 vulnerabilities (11 moderate, 9 high, 2 critical)

To address issues that do not require attention, run:
  npm audit fix

To address all issues (including breaking changes), run:
  npm audit fix --force

Run `npm audit` for details.

C:\xampp\htdocs\n8n-nodes-test>npm run build

> n8n-nodes-<...>@0.1.0 build
> tsc && gulp build:icons

[10:32:26] Using gulpfile C:\xampp\htdocs\n8n-nodes-test\gulpfile.js
[10:32:26] Starting 'build:icons'...
[10:32:26] Finished 'build:icons' after 27 ms

C:\xampp\htdocs\n8n-nodes-test>npm link
npm ERR! code EINVALIDPACKAGENAME
npm ERR! Invalid package name "n8n-nodes-<...>" of package "n8n-nodes-<...>@file:../../../../../xampp/htdocs/n8n-nodes-test": name can only contain URL-friendly characters.

npm ERR! A complete log of this run can be found in: C:\Users\Dell\AppData\Local\npm-cache\_logs\2023-10-30T08_32_28_017Z-debug-0.log

C:\xampp\htdocs\n8n-nodes-test>cd C:/Users/Dell/.n8n/custom

C:\Users\Dell\.n8n\custom>npm link n8n-nodes-test

added 1 package in 3s

C:\Users\Dell\.n8n\custom>n8n start
Initializing n8n process
n8n ready on 0.0.0.0, port 5678
Version: 1.11.2

Editor is now accessible via:
http://localhost:5678/

Press "o" to open in Browser.


Hey @Onlypfachi,

There was an error in your output, This one means that you didn’t update the package name and it is still n8n-nodes-<...>, Can you open the package.json and change the package name to n8n-nodes-test and try again.

C:\xampp\htdocs\n8n-nodes-test>npm link
npm ERR! code EINVALIDPACKAGENAME
npm ERR! Invalid package name "n8n-nodes-<...>" of package "n8n-nodes-<...>@file:../../../../../xampp/htdocs/n8n-nodes-test": name can only contain URL-friendly characters.

npm ERR! A complete log of this run can be found in: C:\Users\Dell\AppData\Local\npm-cache\_logs\2023-10-30T08_32_28_017Z-debug-0.log
2 Likes

Oh i forgot yeah now it works let me add my node now

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.