Change OAuth Redirect URL to https

I want to use a Google sheet update as a trigger for a workflow and I need to create OAuth2 on Google API console. the problem is that Google only accepts URLs with https and the callback URL that N8N has is with http.
can anyone tell me how to change it?
I am using N8N’s latest version and all settings are set to default and I also have Nginx on my server with SSL installed on N8N domain.
I’ve installed my N8N on docker on ubuntu with this command:

sudo docker run -d --restart unless-stopped -it
–name n8n
–env N8N_BASIC_AUTH_ACTIVE=true
-p 5678:5678
-e N8N_HOST=“/n8n.domain.pro”
-e VUE_APP_URL_BASE_API=“https://n8n.domain.pro/
-e WEBHOOK_TUNNEL_URL=“https://n8n.domain.pro/
-v ~/.n8n:/root/.n8n
n8nio/n8n

Describe the problem/error/question

What is the error message (if any)?

Please share your workflow

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Mohammadali_Mo,

You look to be using an older docker run option, Try using the below which brings you inline with the current documentation for using n8n.

sudo docker run -d --restart unless-stopped -it
–name n8n
-p 5678:5678
-e WEBHOOK_URL="https://n8n.domain.pro"
-v ~/.n8n:/home/node/.n8n
n8nio/n8n
2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.