Chat Node giving "empty response"


I am playing a bit with the new Chat Node. I built a small POC for document retrieval which works as expected in n8n.

However, using the “hosted chat” I get “empty response” while in my log I have a response. What could be the issue ?

digi-studio 2024-01-18 at 11.07.34

Information on your n8n setup

  • n8n version: 1.24.1
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npn
  • Operating system: ubuntu
1 Like

After more investigation, I can see the response is received (in the chrome dev tool), but not displayed in the chat.

How are we supposed to format the response to be displayed in the chatbox ?

Hi guys, I`m with the same problem described above. Could you please help us?

Maybe somebody with a working chat window (if there is), could show us the response of the chat query in the Chrome dev tool ?

I tried to reverse engineer the JS code but even with my friend ChatGPT, I am not familiar enough in VueJS to understand :slight_smile:

Do you get the same issue when using an AI Agent? I have just given it a quick go and it seems to be all good using the workflow below.

This indeed worked with a AI Agent.

So I could inspect the response and make it work with a Basic LLM but it is definitely a bit tricky and should be improved or documented.

Here is the trick:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.