Click and Select a node doesn't work in v 1.27.1

Describe the problem/error/question

Information on your n8n setup

  • n8n version: 1.27.1
  • Database (default: SQLite): PostgresQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Alpine docker/ RedHat host

Hello,

Since the update in v 1.27.1 it is not possible to select one node by clicking on it. When we click on a node, it is not surround (like it was in previous version) and all keyboard shortcut (shift right, ctrl click to select nodes) doesn’t work either.

Does anyone else have the same issue with the version 1.27.1 ?

Thanks for your help.

I’m not able to reproduce this so far. Can you please share more information about what browser you are testing this on?
Also, have you tried reloading the UI to see if that fixes the issue?

Hello,

thank you for your help.

I try with Firefox, Edge and chrome and I can’t select a specific node when I click on it since the update. One of my collegue try with another computer and he had the same problem. When we click the node is not selected but when we maintain the click we are able to move the node

I’m unfortunately still not able to reproduce this on Firefox or Chrome. Maybe this is specific to a node type.
Can you share a screen recording with us? if not, maybe a screenshot?

n8n----AttackIQ-Execute-assessment-ezgif.com-video-to-webp-converter (1)

We can’t seen on video when I click but I click several times on the MySQL Node and then on the “Split Out” node. Event when I move the node you can see it’s not surround.

Hey @Kent1,

Are you using a laptop / desktop with a touch screen monitor attached?

Hello,

Yes our laptop have a touch screen.

We have had a few issues with touch enabled screens in the past, I suspect this could be related to that. Do you have a machine without a touch screen you can test on?

I will test as soon as I can. I will let you know.

1 Like

I disable the touchscreen option on my laptop and it’s working again.

Thank you for the hint.

1 Like

I also have this issue. I can’t select nodes after updating to 1.26.0

Hey @peterjaffray,

Do you also have a touchscreen device?

No touchscreen. Also, multiple browsers/devices. Cleaned cache. But note - I am in 1.26.0 using Docker image.

Hey @peterjaffray,

Interesting, I have never seen this happen on a device without a touchscreen. What device are you using to access n8n and do you have the same issue in private browsing mode?

It would also be interesting to see the output of the browser dev console to see if anything odd is there.

When I click and hold, the <body class"katavorio-drag-noselect"> is added to the DOM, but when I release, the node remains unselected. When I click it comes and goes really fast.

There is nothing in the console when I click around, try to select, or try to multi-select. I just noticed the upgrade - completed the upgrade - problem persists.

There is a css class wrapping the node “is-touch-device” - once I removed that everything started working for all nodes.

image

Hey @peterjaffray,

The is-touch-device will appear if it thinks you are using a touch device, Can you share what you are using to access n8n?

I think I might be a one-off case as I checked https://www.deviceinfo.me/ and it does say my browser supports touchscreen for some reason. I appreciate your efforts - but I also respect your time too much. I will figure this out and come back with better information and a solution.

1 Like