ClickFunnels Webhooks

I’m trying to add a webhook in ClickFunnels - following the guide here: https://help.clickfunnels.com/hc/en-us/articles/360039820293-Webhooks-in-ClickFunnels

It works using something like https://requestcatcher.com/ but when I try to connect to a Webhook node in n8n I get and error: Url returned status 401 - ‘Unauthorized’

I have Authentication set to ‘None’

The webhook works if I use a simple HTML form to send data.

Thanks

Where do you get that error? in the click funnel panel?

Yes, when I click on the Create Webhook button it tries to connect then goves the error

When you hit the button “create webhook” is it workflow executing or active? because what might be happening it’s that clickfunnel is sending a ping to verify if URL is valid and since the workflow is not executing or active, the ping never reaches n8n, hence the error.

I’ve tried both test mode and active and get the same result.

I did find this: php - How to add webhook in clickfunnel. it is not accepting my webhook url - Stack Overflow

It suggests adding the directories ‘funnel_webhooks/test’ to the web root folder - how would I try that with the Docker image?

Thanks!

Is it possible that the webhook uses the HTTP Method GET, and ClickFunnels sends a POST? Can you try setting the HTTP method to POST?

Tried with POST but get the same error

Hey @seank1968,

What I would do is in your workflow hit the execute button at the bottom, Update clickfunnel to use the test webhook url and see what it responds with.

It looks like you need to respond to the request within 3 seconds so start simple and make sure there is nothing else in your workflow and see if that does anything.

I would also set the path for the webhook to funnel_webhooks/test to see if that changes anything, The value you use in Click Funnel would be https://n8n.your-domain.tld/webhook-test/funnel_webhooks/test

1 Like

Thanks.

Tried all that, but still getting the error: Url returned status 401 - ‘Unauthorized’

How do you have n8n setup?

Have you tried to make the same request with something like curl to get if you get the same message?

If I just use the URL in a web browsers I get ‘workflow started’ and the header JSON in the workflow

What about your n8n setup? Is it cloud, Desktop, Docker, NPM, Behind a reverse proxy?

It’s Docker on Digital Ocean
I’ll try from the desktop app later.
No reverse proxy

Does it give you anything else? A 401 is normally an Auth failure, it might be worth asking ClickFunnel if they can provide more information.

It looks like they want a card to get access to a trial so it isn’t an easy thing to setup and test.

Click Funnels say it’s an external integration so they can’t help.

Tried on the desktop app with the same result.

I tried with https://pipedream.com/ and it conenects to that ok!

That is a shame, I thought they might be able to give you more on the response. Might be worth testing a connection to your webhook with Curl with the extra logging enabled on the command to see what is coming back but do it from an “outside” machine to see if the same 401 pops up.