ClickUp attachment not working

Describe the issue/error/question

Hey. I’m trying to attach a file from a Gravity form entry, to ClickUp attachments section. The problem I have is that if the ClickUp connection is done with Basic Auth, I got the error that there is no auth token. And when I try to connect with OAuth2, I can’t connect to ClickUp. This is driving me crazy. Here are the details from OAuth2

Please share the workflow

Hi @Darius_Dumitru, I am sorry to hear you’re having trouble.

Your screenshot suggests you’re using the generic OAuth2 authentication for ClickUp. In recent n8n versions you can re-use OAuth2 credentials from your existing nodes by selecting “Predefined Credential Type” in the Authentication field like so:


I just tried this on my end and it seemed to work fine:


Could you give this a go on your end (you might need to upgrade your n8n version to avail of this authentication approach in the HTTP Request node) and confirm if you’re still facing any trouble afterwards?

Thanks a lot @MutedJam. It works now! But I see an error on the “get1” node (which is the gravity form file). If the file name contains any of these letters “ăîșțâ” it throws this error:“Request path contains unescaped characters”.

Do you have any idea how can I solve this?

Found the solution here. Just had to use this in the get1 node: {{encodeURI($node[“Set2”].json[“Attachment”])}}.

1 Like

Awesome, glad to hear this works for you! Thanks for confirming :slight_smile: