ClickUp don't trigger

I’m able to create a task in ClickUp via n8n with this workflow

But when I want to trigger ClickUp it simply doesnt work.
What I tried so far…

  1. as event I tried * since the default one task.created does not work
  2. adding filter since (to create a task I add to create a folder to retrived the id)
  • n8n 1.29.1 run via cloudron on Ubuntu 22 as a docker container.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @JOduMonT,

If you check the webhook url in the node does it still show as http://localhost:5678 or does it show your domain?

If it does show as localhost setting the WEBHOOK_URL env option will help, If it is showing as your domain does Clickup show any errors for the connection?

sorry I don’t understand;
I started the trigger and look in my logs
on the n8n nothing show up

Hey @JOduMonT,

Is the URL correct, It is worth starting there first.

1st; thanks for your patience and help :wink:

2nd; maybe I’m wrong
but when n8n trigger is waiting for a new task under Sotthi

n8n Side

waiting for an update in a list

waiting for a task to be create

I create a task in the List which is under Sotthi

ClickUp Side

image

and nothing happen :frowning:

Hey @JOduMonT,

Is the URL correct or does it show localhost?

Please click on webhook URL and tell us what the URL is.

untitled

It should be your full custom URL with https://. If it is localhost:5678 it means you didn’t set the WEBHOOK_URL env option on setup and that would be the fix

1 Like

yes test and prod webhook URL point to my public domain

Does it have the full https:// prefix?

Usually doesn’t work without it. I had an issue with clickup triggers where i had a typo in https and triggers weren’t working, when i fixed the typo it started working.

Also, sometimes i have found it can take up to a minute for the events to come in from clickup

Also, for now for your testing set the event to * which will send all events. (unless you have others doing stuff that will keep triggering it)
But that will tell you if it’s your issue or clickups issue

my link is fine; I have plenty of other workflow which works
and my n8n instance is part of Cloudron which is used my few thousand users
my webhook URLs looks like this: https://n8n.domain.tld/webhook-test/5f1f19a4-0609-4a64-b789-8ffc6d5aaad6/webhook

Sorry; I tried and let the workflow timing out without success

  • is not working too

also tried a different workspace

Hey @JOduMonT,

Does a normal webhook worklfow work ok? I have just tested the clickup trigger on my n8n install and it appears to be ok. I personally don’t use Cloudron as to me it is another layer in the process that doesn’t need to be there.

Don’t mean to beat a dead horse, that is just the most common issue. People post about this all the time and it is almost always that.

Like @Jon asked, does the regular webhook trigger work ok for you? The clickup trigger is essentially just a webhook trigger under the hood, it just registers the url for you (which is why it’s important for it to be set correctly)

It could also be a firewall issue or getting mixed up in your reverse proxy, so check all of the relevant logs and see if anything is being blocked.


As a trouble shooting step you can set up a normal webhook trigger. Then manually subscribe to the clickup webhooks with an http node using the webhook url. This is what the clickup trigger does under the hood.