ClickUp Trigger not firing at all

I have a Click Up Trigger set up, with the Events tasks.status.updated and filtered to a Space, Folder and List.

I have confirmed the setup at ClickUp with a call to Click Ups Get Webhook endpoint:

[
  {
    "webhooks": [
      {
        "id": "11f2e31e-895b-4411-97a9-192463282193",
        "userid": 2796716,
        "team_id": 6944990,
        "endpoint": "https://myurl.app.n8n.cloud/webhook/ABC/webhook",
        "client_id": "ABC",
        "events": [
          "taskStatusUpdated"
        ],
        "task_id": null,
        "list_id": 900302354248,
        "folder_id": null,
        "space_id": null,
        "health": {
          "status": "active",
          "fail_count": 0
        },
        "secret": "ABC"
      }
    ]
  }
]

However, it never fires, there are no executions. I go into ClickUp, change a few task statuses within this space, folder and list, and there are no executions in n8n recorded. Workflow settings are to record all executions (success and fails)

I also tried a global catch-all trigger (all events, no defined space, folder or list), and still no executions.

I’m running n8n cloud, running version [email protected]

My ClickUp credentials work, as I use them for other ClickUp nodes elsewhere, such as getTasks, updateTasks etc.

I have also made a separate workflow, to fire an HTTP POST request to my n8n trigger Test URL https://myurl.app.n8n.cloud/webhook-test/ABC/webhook, whilst listening for executions of this ClickUp trigger and this HTTP Post returns:

[
  {
    "message": "Webhook call received"
  }
]

However the Click Up trigger in test mode does not pick it up and stays on “Listening for event”.

Am I just in need of more coffee and missing something obvious, or is something else going on? Quite odd that a manual POST to my testing endpoint doesn’t record any execution…

Thanks
Rob

Ooohhhkay, so about five mintues after posting this, it just started working and catching executions as expected.

Can only think there was some webhook downtime at ClickUp, or there’s a delay between creating a webook and it starting to fire from ClickUp.

2 Likes

Oh, great to know. I’ve had the same issue, and was not patient enough to see it running in 5 mins, so i’m just re-running the whole workflow by timer :slight_smile:
Thanks for the info!

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.