Community node package not updating after npm version patch, build, publish

Hello, I published a community node 7 days ago. A bug got fixed so I’d like to publish an update for this node.

I did the following, after fixes were visible on localhost:

  1. npm run build
  2. npm version patch
  3. npm publish

There were no errors and new version appears in npmjs. Upgrade button appears in community nodes and latest version can be selected for my node.

However, when I open the node, the fixes are not visible, node looks like the previous version, although was updated in settings to latest version. Readme was updated after the npm publish.

Please help me with a suggestion, maybe I skipped some steps or did not update the package correctly. I tried to:

  • Reinstall the node.
  • To version patch it before the build command
  • Ran prepublishOnly before the publish command

All with same result.

Thank you!

Hey @alexnemes,

Have you tried restarting your n8n instance?

Hey @Jon,

Tried and changes are visible now.

Thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.