Community Nodes Issue - "n8n detected that some packages are missing"

Describe the issue/error/question

I’ve gotten this error since I started using community nodes and sadly I haven’t found any information on it. I did try a docker image thinking that persisting the root path would solve the issue, but it created even more problems when that didn’t work - Ended up also trying to force download the nodes every time n8n reboots, but it ended up creating multiple duplicate entries in the DB, resulting to a corrupted database. I’ve tried SQLite and MariaDB instances and same result. I would appreciate if anyone could give insight into how to solve this.

EDIT: I realized that ipc is used as a dependency by the Discord community node - so that might be a separate issue. However, why am I still receiving the missing packages error?

What is the error message (if any)?

Server path not specified, so defaulting to ipc.config.socketRoot + ipc.config.appspace + /tmp/
starting server on  /tmp/ 
starting TLS server false
starting server as Unix || Windows Socket
ipc bot server started
n8n detected that some packages are missing. For more information, visit
n8n ready on, port 5678
Version: 0.204.0
Service path not specified, so defaulting to ipc.config.socketRoot + ipc.config.appspace + id 
requested connection to  bot /tmp/
Connecting client on Unix Socket : /tmp/

Information on your n8n setup

  • n8n version: 0.204.0
  • Database you’re using (default: SQLite): SQLite / MariaDB
  • Running n8n via [Docker, npm,, desktop app]: npm / Docker

Hi @TheSmilez, I am sorry you’re having trouble.

I am not sure I’ll be able to provide much help here tbh, so we might need to wait for smarter people to jump in on this. Can you confirm how exactly one can reproduce the exact error you are facing?

Heya @MutedJam! I found out the issue with ipc is strictly between the community node itself and ipc. But as for the n8n error, it still persists. I’ve posted a thread on GitHub as well: n8n detected that some packages are missing. · Issue #4771 · n8n-io/n8n · GitHub

As to the steps, it’s pretty simple, really…

  1. Install n8n
  2. Install a community node
  3. Shut down n8n
  4. Run n8n again
  5. See error

As stated in the Git issue, the odd part is that the community nodes still appear to work fine despite both the error on console and the browser

1 Like

Oh, good spot. I didn’t even notice this problem - my community node seems to work fine, so I didn’t specifically check for errors (but I sure can see it now).

I’ll add this to our engineering team’s backlog to make sure this gets looked at.

1 Like

Thank you, much appreciated. :pray:

1 Like

Seems like the team already got to it.

Thanks again @MutedJam!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.