Confused re: Schedule node executing at the same time every day

I’m using the Schedule node in two workflows, and getting unexpected results as to when it executes.

The first is set to execute every 53 hours, at minute 45:

But it is executing every 24 hours, at minute 45:

The second is set to execute every 27 hours, at minute 45:

But it is also executing every 24 hours, at minute 45:

I have read the documentation on the Schedule node but don’t see what could be causing this based on my settings. I also searched the forum and saw a lot of discussion re: the old cron node, but not this problem for the Schedule node.

I don’t really care what minute it executes at, so I tried putting nothing in the “Trigger at minute” box in the Schedule node, but that just made it revert to minute 0.

I have other workflows that use Schedule as triggers, but they are set to run every 1 hour, every 10 mins, and every 5 mins. Those all execute properly / as I expect based on my settings in the Schedule node.

Am I misunderstanding how to set up the Schedule node?

Thank you!

Information on your n8n setup

  • 0.202.1 self hosted, installed with Docker per the n8n documentation.

Hi @mmac, the schedule node is essentially a combination of the old cron node and the interval node. I remember the latter having trouble when intervals where longer than the next largest unit (as in more than 60 minutes, or more than 24 hours). I too found this super confusing but found out it was the expected behaviour back then :frowning:

Perhaps you can consider either using a proper cron expression to run your workflow or switching to a different unit? E.g. instead of running your flow every 53 hours, simply run it every 2 days?

I know this isn’t a great experience, so please accept my sincere apologies for the confusion this causes.

I adjusted the workflow to execute every 21 hours, but it’s still executing at odd times.

My settings:

The times it’s executed:

So it’s executing at hour 21 of every day, not 21 hours apart. And then I have the minute set to 40, and it’s trying to execute again at 00:40 every day. It’s failing on the 00:40 time because it’s a duplicate status on Twitter - Twitter doesn’t allow the same post to be posted 2x in a row - but it shouldn’t be executing then in the first place.

The workflow:

Bumping this. I’m still experiencing the Schedule Trigger not executing as specified, as illustrated in my Dec 6 post.

Hi @mmac, thanks for the reminder! I have create a simplified test workflow on my own instance running the current version 0.208 of n8n to verify whether I’m able to reproduce this.

Hi @mmac, I was able to reproduce this problem and have added this to our bug tracker for a closer look by the engineering team.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.