Connection to Notion Api using key is failing

Describe the problem/error/question

We are trying to set up Notion node for a workflow to access the Database in Notion. For that we were trying to set up the credentials using Notion api key.

I created an integration with read, write and edit access in Notion. Also connected to the database but No data is returned when the node was executed.

What is the error message (if any)?

Couldn’t connect with these settings

Please share your workflow

“meta”: {
“instanceId”: “4a1d5d5144e1d06fa84217c508c3d70bbe46964ac5177d5b51e46752455d094c”
“nodes”: [
“parameters”: {
“resource”: “database”,
“databaseId”: {
“__rl”: true,
“value”: “”,
“mode”: “url”,
“__regex”: “(?:https|http)://[a-z0-9-]{2,}/)?([0-9a-f]{8}[0-9a-f]{4}4[0-9a-f]{3}[89ab][0-9a-f]{3}[0-9a-f]{12})”
“id”: “afc76e6c-1d95-4030-9a91-e20ad57125c8”,
“name”: “Notion (Beta)”,
“type”: “n8n-nodes-base.notion”,
“typeVersion”: 2,
“position”: [
“credentials”: {
“notionApi”: {
“id”: “71”,
“name”: “Abhay’s workspcae”
“connections”: {}

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • **n8n version:[email protected]
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):cloud
  • **Operating system:windows

Hi @Abhay, I am sorry to hear you’re having trouble. Can you confirm if your Notion credentials are working despite the error message?

I too am seeing this error when using [email protected]:

Actually executing the Notion node does, however, work fine:

Hey @Abhay,

Our node has an option to get users as well so under the User Capabilities we would also need the Read user information without email addresses option. Our credential test also uses this endpoint to make sure we can connect as it will typically use less data than some of the other options.

Can you set this and let me know if it works.

1 Like

Hi @MutedJam, I tried executing the Notion Node. No error is showing but no value is appearing.

Sounds like it’s working then :slight_smile:

To actually see data in n8n you’d need to share pages/databases with your new integration.

For the credentials check to work you could also add user details to your integration permissions in Notion.

1 Like

Hi @MutedJam,

I added the User permission also to the notion integration. Like given in the question is the integration is already added to notion page and that has the database.

Is there anyother steps to do, I’m still not getting any response after running the notion node.


Hi @Jon,

There are no outputs but it is showing that the connection test is successful after doing this.

Have you added the Notion integration to the page you want it to access?

Yes It was done already. I have attached it in the screenshot along with the question.

It is working now I’m able to collect info from database now. I think it took some time to reflct the changes in Notion and n8n Notion Node.
Thank you @Jon and @MutedJam


In other news I have pushed a PR that changes the API call we make to validate the credential so this won’t be an issue in the future.


New version [email protected] got released which includes the GitHub PR 6022.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.