Cortex Binary Data issues

Hi @Team.
I’m facing some issues with binary data.

The error displayed

The Value extracted from imap node with binary data

Tried to use the Node Move to Binary but when i execute it i got no response data.
I took the source from Imap node as well.


Can you please help me to understand this?

Hey @hermanmaleiane!

The second image that you shared only returns the name of the file and not the content of the binary file. You need to enter the Binary Property Value that is returned by the IMAP node. Looking at your screenshot, the Binary Property Value of your file is attachment_0. Hence, in the source field where you want to fetch the binary file, you have to enter attachement_0.

In n8n (in most of the cases), you can refer to the binary files by the Binary Property value, and not the name of the file.

Hope this helps :slight_smile:


Additionally to what @harshil1712 wrote would you probably also have to add a Merge-Node between nodes named “TheHive” and “Cortex”. That Merge-Node would have as input 1 the “TheHive” and as input 2 “IMAP EMail”. The “Mode” you would have to set is “Merge By Index”.

That is needed because the binary data will not be available anymore, as it will get “lost” after “TheHive1” node. With the Merge-Node you can merge it in again so that it is available to be used by the “Cortex” node.

Thanks @harshil1712 and @jan.
Got the same error. I think what @jan said is the next thing to do as it seems data in attachment_0 is lost.

Screenshor 2

Something like this?

Hi @harshil1712 and @jan. Thanks for you inputs. it worked.
One more question please.

Job is created successfully but data is not being returned in the step where the analyzer is running.
Is there any reason for this?

This shouldn’t be the case. If the execution was successful, you should get some output. In the Settings tab of the node, can you enable the Always Output Data option? (Ideally, this is not required)

Sorry @harshil1712 , i noticed that sometimes analyzer does not run but it says work flow completed successfully.
This time i didn’t found nothing in Cortex.
And when i enable the Always Output Data it passes for another step but without any data.

i added a separted node for cortex and tested, i got the values returned.
It only happens on the workflow.



Can you please also post a screenshot of the parameters + output of the node when it runs inside of the workflow.

Hi @jan


The cortex node is not returning output.