Couldn’t connect with these settings ETIMEDOUT

Describe the problem/error/question

I have tried installing and reinstalling 3 times. But I still don’t understand why I still get the error below.
I can’t set up a telegram account.

What is the error message (if any)?

Couldn’t connect with these settings

Retrying

ETIMEDOUT

Please share your workflow

Share the output returned by the last node

0|n8n      | User settings loaded from: /home/sysadmin/.n8n/config
0|n8n      | 2024-04-23T11:20:08.170Z | info     | Initializing n8n process "{ file: 'start.js', function: 'init' }"
0|n8n      | n8n ready on 0.0.0.0, port 5678
0|n8n      | Version: 1.37.3
0|n8n      |
0|n8n      | Editor is now accessible via:
0|n8n      | https://n8n.*******.net:5678/

0|n8n  | 2024-04-23T11:20:23.115Z | verbose  | Execution for workflow My workflow was assigned id 8 "{\n  executionId: '8',\n  file: 'WorkflowRunner.js',\n  function: 'runMainProcess'\n}"
0|n8n  | 2024-04-23T11:20:23.124Z | verbose  | Workflow execution started "{\n  workflowId: '7rWgGqKdMoVye9bM',\n  file: 'LoggerProxy.js',\n  function: 'exports.verbose'\n}"
0|n8n  | 2024-04-23T11:20:23.130Z | verbose  | Started execution of workflow "My workflow" from webhook with execution ID 8 "{\n  executionId: '8',\n  file: 'WebhookHelpers.js',\n  function: 'executeWebhook'\n}"
0|n8n  | 2024-04-23T11:20:23.523Z | verbose  | Workflow execution finished with error "{\n  error: {\n    level: 'warning',\n    tags: {},\n    extra: undefined,\n    context: {},\n    functionality: 'regular',\n    name: 'NodeApiError',\n    timestamp: 1713871223521,\n    node: {\n      parameters: [Object],\n      id: '0b07abb2-42f0-4811-9ee7-6624feb0aba5',\n      name: 'Telegram',\n      type: 'n8n-nodes-base.telegram',\n      typeVersion: 1.1,\n      position: [Array],\n      credentials: [Object]\n    },\n    messages: [\n      'connect ETIMEDOUT 149.154.167.220:443 | connect ENETUNREACH 2001:67c:4e8:f004::9:443 - Local (:::0)'\n    ],\n    httpCode: 'ETIMEDOUT',\n    description: undefined,\n    message: \"The connection timed out, consider setting 'Retry on Fail' option in the node settings\",\n    stack: \"NodeApiError: The connection timed out, consider setting 'Retry on Fail' option in the node settings\\n\" +\n      '    at Object.apiRequest (/usr/lib/node_modules/n8n/node_modules/n8n-nodes-base/nodes/Telegram/GenericFunctions.ts:218:9)\\n' +\n      '    at processTicksAndRejections (node:internal/process/task_queues:95:5)\\n' +\n      '    at Object.execute (/usr/lib/node_modules/n8n/node_modules/n8n-nodes-base/nodes/Telegram/Telegram.node.ts:2053:21)\\n' +\n      '    at Workflow.runNode (/usr/lib/node_modules/n8n/node_modules/n8n-workflow/src/Workflow.ts:1378:8)\\n' +\n      '    at /usr/lib/node_modules/n8n/node_modules/n8n-core/src/WorkflowExecute.ts:1050:29\\n' +\n      '    at /usr/lib/node_modules/n8n/node_modules/n8n-core/src/WorkflowExecute.ts:1726:11'\n  },\n  workflowId: '7rWgGqKdMoVye9bM',\n  file: 'LoggerProxy.js',\n  function: 'exports.verbose'\n}"

Information on your n8n setup

  • n8n version: 1.37.3
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): Default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system: Ubuntu 22.04 LTS

Hello @tohuenet

The ENETUNREACH usually means that the n8n doesn’t have access to the internet. Maybe there are some firewall rules blocking access or interface issue (ipv6?)

1 Like

Thank you for the reply. That’s problem of ipv6.
I have disabled ipv6 of Ubuntu then it works.