Couldn’t connect with these settings

Guys, I need some help. I have a custom node that the connection test always displays “Couldn’t connect with these settings”. I analyzed the example of Postgres, FTP, Redis and other nodes, but none of them worked.

credentials: [
				name: 'oracleSqlApi',
				required: true,
				testedBy: 'oracleConnectionTest',

When enabling the testedBy parameter, the message “Couldn’t connect with these settings” starts to be displayed on the connection screen. I can connect normally to Oracle but I believe that the connection test function is not being called as it does not display logs or feedback.

I tried this way, like the Postgres V2 example

I tried this way, like the Postgres V1 example

I tried several ways, none of them can call the connection test function.

An interesting test I did was to configure the test command in the OracleSqlApi.credentials.ts file: ICredentialTestRequest
With this command, the error logs are displayed in the vscode console.

I’m new to developing nodes for n8n, and I couldn’t understand why the connection test doesn’t work on my node even though I followed the examples of other nodes exactly. If anyone has any tips, any help would be appreciated. Thank you very much in advance.

Information on your n8n setup

  • n8n version: 1.21.0
  • Database: Postgres
  • Running n8n via: NPM in VSCode
  • Operating system: Windown

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

it says that the credentials testing function does not exist even though it exists, I followed several examples from other nodes but mine does not work. where am I going wrong?

Hi @leomangueira, I am sorry you’re having trouble. Perhaps you can share your repo for a closer look and one of our node builders (@marcus or @Jon) can have a closer look?

1 Like

This is on my list still to look into, I think we have a GH issue open for it as well so it does look like this this is a bug that needs to be fixed rather than something in the node like I originally thought.

The dev ticket for this is PAY-1274.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.