Course level-1 Discord notification failing but output node successful

Hi, the Discord node says success but there is no notification in Discord

the workflow:

Information n8n setup:

  • n8n version: 0.219.1
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via: Docker

thanks for your help

Hey @headset907,

Can you share your ID? That will let me check what has happened, normally the message won’t get sent if the id is not valid or if the doesn’t match what we expect.

Thanks @Jon, sure it’s: recyEEwwqVHn4bQHv

Hey @headset907,

Can you try again and let me know once it is done, I had to enable logging on that endpoint :slight_smile:

hi @Jon, the workflow was successful but still no notification in Discord! :face_with_diagonal_mouth:

Hey @headset907,

That is fine I wasn’t expecting it to work I just needed the attempt so I could check the log output, I will let you know what I find.

Hey @headset907,

I checked the logs and I can see the message you sent come in, It looked a bit odd though so I checked your workflow again and on the Discord node you have not set the content to use an expression which is causing your issue.

Hey @Jon, I think I understand sort of but should I hard code my ID like this:

or should I drag and drop something from the variable selector column? I tried the ones under headerParameters but none of them gives me my ID value…
thanks a lot

@Jon , I hard coded my ID in the expression and the notification is going through the Discord

but it’s not the result I’m getting in the node, what am I doing wrong?


Also in my previous post I was asking you if I have to hard code my ID or if there is another solution:

Thanks a lot for your help @Jon

anyone could help me?

Hey @headset907

Can you share the full workflow again? It looks like it should be working but the expressions are not being picked up properly so I would like to see what you are doing.

hi @Jon, sure:

(the nocodb node works in my workflow I don’t know why it shows up with an error when I copy paste it…)

@Jon any idea? thx

Hey @headset907,

It looks like you are still not using an expression in the Discord message. If you toggle that it should start working.

hey @Jon, I’m clueless on this one, what toggle switch are you talking about? in the Discord node I don’t see any…

Are you talking about the Additional fields?

I’m so close, I want it to work! thanks

Hey @headset907,

If you toggle this option it changes the field to accept expressions.


If you have it right you will see something like this…


Thanks @Jon, I tripled check everything and I still have the ID undefined:

but the expression seems correctly set:

I also verified the HTTP node and everything is correct:

I must be missing a last final detail but I have no idea which one… :anguished:

also I’m noticing that the header auth account credential keeps modifying my header auth value…

could it be the problem’s reason @Jon? thanks

Hey @headset907,

Don’t use an expression for the header auth or you will see the blank value we send to the front end to protect the credentials.

To get the correct value for the ID you can use the variable selector to get it…

Or the quick version would be to use {{ $node["HTTP Request"].parameter["headerParameters"]["parameters"][0]["value"] }} we changed the value in a recent version of n8n and have not updated the course yet.

1 Like

@Jon !!! that’s it !! sucess!!!
Man, I really appreciate you sticking with me. Thank you! :slight_smile:

1 Like