Credential authorization form for Microsoft OAuth (and others) is truncated

Describe the problem/error/question

I have tried (in multiple browsers and in & out of incognito mode) to get a Microsoft Outlook node created in one of my workflows. Folllowing religiously the instructions provided, I note that I never see any inputs. The form is simply truncated. I’ve tried this on a handful of different authentications and they seem to be missing fields, too. So I’m wondering if there is something in my setup that makes these fields not show.

Information on your n8n setup

  • n8n version: 1.29.1
  • Running n8n via cloud
  • Operating system: Mac

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

hello @wildcat63

On local n8n everything is ok. Try to clear the browser cache

Thanks for the reply and the screenshot of what I should be seeing.

I disabled the cache and reloaded. Same thing. I created a new workflow. Same thing. I checked the html to see if the additional fields were there but hidden, but they just weren’t there.

Feeling stuck, unfortunately. I’m on a paid plan (the “Pro” plan which makes my workflows a bit easier to debug), but there doesn’t seem to be any access to support until “Enterprise”.

If anyone has ideas, please let me know. Thanks in advance.

So I ended up trying a completely different browser that I had never signed in with n8n or a Microsoft account. And it worked … but the form that @barn4k showed doesn’t show up. It’s just the abbreviated one I showed earlier. Perhaps an update to n8n’s documentation for connecting to Microsoft is needed.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.