Credential unauthorized

hello, since i have updated the n8n to latest version, i am unable to obtain workflow using basic authorization.

I have not create a user account, and basic authorization is setup during docker install.

Hey @Benjamin123, this is an unsupported and undocumented API used by the UI which can change at any point in time. I try to make this clear whenever it comes up on the forum, apologies if I have missed it in your case.

That said, here is a large warning on the changelog about this:

Upgrading to any n8n version that includes user management will cause calls to the frontend API to break.

I suspect you could work around this by performing the requests made by the frontend when logging in and then use the auth cookie for your workflows request, but I haven’t tried this yet and won’t be able to in the next days from the looks of it.

So if you don’t want to do the discovery work yourself your best bet would be to use a version of n8n without user management for now and wait for a public REST API to be built and released. This will make things much simpler :slight_smile:

I had to workaround this for my backup workflow. Some /rest endpoints now need a JWT in addition to basic auth. You’ll need to do a single auth request before this, then add a Cookie header in subsequent requests. The JWT expiry seems to be a week, so you should only have to do it once per workflow rather than before each request.


Nice, great to see you’ve already figured this out. Thanks for sharing @pemontto!


Thanks @pemontto

This solved my issue.

1 Like

could you explain how to configure the JWT? I’m trying but unfortunately I can’t get it to work

For sake of completeness, here’s the official response:

Yes, that is sadly known as the authentication works now totally different and got also called out specifically here:
User management | n8n Docs

Meaning it will also not get “fixed” as we do not see it as a bug. It will be possible again with the upcoming official API

If you require access to the internal API, then it is best to disable Use Management again.