Credentials for Xero

The OAuth 2.0 redirect that the Xero node on n8n providing is an HTTP one but the Xero app creator will accept only HTTPS

receiving Error 500 - Xero can not connect

I’m running with a cloud n8n

I’m on self-hosted, but I just checked and N8N definitely does the OAuth redirect in HTTPS. Are you able to provide a screenshot of the OAuth Redirect URL from the Xero OAuth2 API credentials, ideally with the domain of your cloud instance blurred or blacked out?

1 Like

Hi @Tomer_Rabinovich, welcome to the community :tada:

In addition to what @cleveradmin said I just gave this a go on my own n8n cloud instance and it seems n8n cloud requests an HTTPS redirect for me when authenticating with Xero. When inspecting the network traffic during the OAuth dance you can see the redirect URL (

The connection itself also worked fine for me:

I couldn’t find an n8n cloud instance under your forum email, but if you’re running into trouble here perhaps you want to make sure you are on a recent version of n8n? I tried the above on 0.207.1. You can check your version and request an update on

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.