Crippling Unexplained Connection Issue (Urgent)


I’ll start off by saying we have $310,000+ in client retainers about to be lost due to this issue, and it’s urgent.

We’re receiving the error seen in the attached screenshot preventing us from performing any executions or performing basically any action inside of the platform.

Screenshot 2023-04-26 at 4.24.16 PM

Over the last 24 hours, I and our dev team have tried to get a basic installation of N8N to work and the error continues to exist.

Before we go down the usual rabbit hole of everyone asking for the specs of out set up and/or server, it’s all of them. We’ve tried every possible way to deploy and use N8N we could find over the last 2 days and the 24 hour bender we’ve all been on trying to rescue these clients.

Elestio, digital ocean, AWS, EasyPanel, various Docker setups, Heroku, LightSail, hosting it locally, multiple “one click” installs, 3rd party packages from GitHub, EVERYTHING.

The only thing that seems to work is the N8N desktop app, which isn’t scalable or sustainable.

We’re out of options and can’t find a single solution.

Our dev team has worked as dev leads for Meta, and Google and have experience in machine learning as well as myself. After 19 straight hours at our desks, we can’t solve this so we’re coming to you guys here in a last-ditch effort.

Thank you for any support you’re able to provide.

1 Like

I’ve been researching, uninstalling and reinstalling as well…I am having the same issue. At first it was only new workflows, but today it is stopping our old workflows as well.

Welcome to the community @MatthewSabia !

Sorry to hear that you have problems. I assume the server is not down and n8n is actually up? Then it is probably really a connection issue. Are you sure no firewall or something similar is blocking the connection? Did anything else change? Upgraded n8n, upgraded your operating system, your anti virus, …? Is it happening on every computer that tries to connect with every browser?

Apart from that, could you try the way n8n connects. By default, it is using Server-Sent Events. You can change it to WebSocket by setting the environment variable:


Ah and please provide as much information as possible, especially the information we have in our template which got deleted instead of filled. Right now we do for example not even know which n8n version gets used.

But generally considering that you have the issue with literally everything except running it locally it almost sounds like it is potentially related to the local machine. So would really try a few different ones to see if that helps to find what is going on.

1 Like

…this worked…

I want to touch your face Jan… But can you offer a little more insight as to why? I would love to understand more about it and prevent this issue from popping up again in the future.

On that note I would love to chat in general about how we would love to make and keep n8n as a core part of our business and brainstorm some ideas.

Thank you so much.

Super happy to hear that it helped! Generally, sadly no idea why SSE gets blocked. I would still expect something on the client side rather than the server side, esp. considering you tried so many different providers. For me, all the SSE setups still work fine but I am for example also on Linux so not really representative. So wonder if some OS, browser, AntiVirus, or Firewall update could be the reason for the issues you faced.

Apart from that always happy to have a chat regarding extending your usage of n8n.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.