[CRON] CRON did not continue running after 15 hours, how to solve

the flow started to pause yesterday at 27 Nov at 16:16:22
and it was supposed to continue today 27 Nov at 08:00:00

Is there a problem with cron or do I need to configure something in ENV?

Information on your n8n setup

  • **n8n version:1.17.0
  • Database (default: PROCESS):
  • n8n queue:
  • Running n8n via (Docker):
  • **Operating system:ubunto

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Ruan17,

There are 2 items going into that wait node, Would they both have worked out to 8am as well?

no, the first item had 0 seconds and the second should be to exit the pause at 8 am

Hey @Ruan17,

Has it run the workflow yet?

Yes, and I’ve already done other tests and it seems that the node wait is not working in production

I did other tests, and the wait still doesn’t execute when it gives the time.

Hey @Ruan17,

Interesting, I did some testing and for me the wait node appears to be working, Have you set the GENERIC_TIMEZONE and TZ environment variables to the correct timezone?

I have - GENERIC_TIMEZONE=America/Sao_Paulo

How do I configure the TZ?

the VPS TZ is not configured

The TZ option for n8n would be the same, Create an env option for TZ and put in the same value and see if that helps. As a quick test you could just do a 5 minute wait to see what that does which is what I did for testing.

i put the tz into the machine and it worked now i will see it in 1 day

@Jon I managed to solve the problem, put the timezone and TZ in the n8n’s ENV and the timezone on the machine, but another question arose when automation is on wait waiting for the time and the machine is restarted and when I see the wait process it shows as an error, Is there a way to resolve this? so that even if the machine is restarted, it remains in the saved wait state

Hey @Ruan17,

I will need to test that my understanding is that when a wait is over a couple of minutes it gets saved to the database for the future so if it does restart it should continue. I will restart my instance later today and see what happens.

Hi @jon, I’ll be waiting for your response.

how was the test @jon
Were you able to test the wait by restarting the machine @jon

Hi @Ruan17,

Sorry for the delay I was caught up with some other issues, I have creted a workflow with a wait node that is set to wait for 5 minutes I have then restarted the container and the wait had not errored so I also stopped and started the container and it still looks to be waiting.

I will know in 2 minutes if it will run fully without erroring.

Alright so for me the node has continued to wait after the restart and has finished without error. In my environment I am using Postgres 14 and n8n 1.19.5.

I’m using version 1.18.2, I’ll check to update, and test, Postgres I’m on the same version

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.