Cron node is not activated, while workflow is

Describe the issue/error/question

My cron node says: “This workflow will run on the schedule you define here once you activate it.
For testing, you can also trigger it manually: by going back to the canvas and clicking ‘execute workflow’”, despite the workflow is active.
I also suspect that the workflow was not executed for quite a while, despite cron is configured for a daily executions.

What is the error message (if any)?

None… =(

Please share the workflow

Share the output returned by the last node


Information on your n8n setup

  • n8n version: 0.185.0
  • Database you’re using (default: SQLite): N/A
  • Running n8n with the execution process [own(default), main]: default
  • Running n8n via [Docker, npm,, desktop app]: Docker

Did you set your timezone in n8n accordingly? Because if not it would explain why it does not execute at the expected time? Or do you have it running longer than 24h and nothing happens? In this case I would suspect that you did not configure n8n or the workflow to save successful executions.

Thank you for a prompt responce!
Timezone is there, it’s not running longer than 24h; my main concern is why cron node consider itself to be not activated?

Is there a chance you are sharing your n8n database between multiple n8n instances? This can lead to unexpected behaviour.

If not, can you try disabling your workflow and then activate it again and then double-check it actually runs next time it’s scheduled?

Not a chance. Tried to disable and enable workflow as well.
The funny thing is that according to the executions log it executed on time. But when I open the node it still says that I need to activate it.

Sounds like it is working then.

This warning is hard-coded, so it shows up for active workflows as well:


Agh… my problem is about the hardcoded message then :slight_smile:
Any chance to enable it only if the workflow is not active, hide it after I click ‘activate’ or rephrase it at least? :slight_smile: