Custom HTTP request on Wise API - Auth issues

Describe the problem/error/question

The Wise node, although thorough, lacks some functionalities (in general, there is not option to do operations on SAVINGS account types, only STANDARD). Normally I would just run the API requests via the HTTP node. However, the Wise credentials do not show up on the “Predefined Credential Type” dropdown menu. It is also unclear to me how I would create a custom credential using the API token and the SCA Private Key.

Any input on this is appreciated!



Hey @KenupCF,

Looking at the node we have not updated it to use the newer credential format yet which is why it can’t be selected as an option in the HTTP Request node, To work around this you would need to manually implement the authentication Wise requires.

Looking at the code for the node you would need one Header credential that sets Authorization to Bearer YOUR_API_TOKEN then for SCA Requests if needed in the response you would need to manually sign the x-2fa-approval header value and generate a signature to send back, This should be possible with the code node or maybe the crypto node but this may not be an easy task.

1 Like

I see. Thanks for the reply !

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.