Custom polling on Clockify trigger not works properly?

Hi! I’m trying to create a Clockify trigger to check new entries, and I have some issues with the polling interval (I saw similar posts, but not about this exactly):

If I set to “every minute”, seems that not works, so I decided to try with custom polling.

If I try to set this custom polling, if I put “every minute” in cron format (* * * * *)
imagen

I get the following error when I try to save the Workflow
imagen

I tried to put every 2 minutes, 5, etc. (*/2, */5) but I get the same error.

Is this cron config works in other way?

Hey @netyaco,

That is a good spot, It looks like the internal polling settings might need updating. I have created NODE-603 as our internal ticket to look into this further.

Thanks for your response!

It’s good to see that all these little things are taken into account, and that’s why this project improves every day. Being able to contribute to improve it is the least we can do :wink:

Best regard, and congratulations for this amazing project!

1 Like

Hi @netyaco, in the meantime perhaps you want to consider using n8n’s webhook node instead of the Clockify trigger?

You can set these up in your clockify profile:

In n8n you’d then set up a webhook node listening for POST requests and would get your events with all relevant details instantly and don’t have to worry about polling:

1 Like

Hi @MutedJam, this is the option that I have choosen :slight_smile:

Thanks for your recommendation!

2 Likes

Alright so quick update on this one… The custom cron expects the first value to be seconds so if you set that to 0 (or similar) then use 0 */1 * * * * it should active. I am going to do a bit of testing to see if the custom cron supports the more standard format and if it does I will get the check updated.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.