Data transformation binary utf8 to HTML

Hi all,
I would like to extract HTML code from http get and the result is not HTML, it’s look like binary, utf8.

I already tried the move binary data, but I still have the same result.

Do you have an idea ?

Hi @hob,

Welcome to the community :cake:

Don’t forget to fill out the template it can save time and lets us move quickly when answering questions, Can you share the last 2 nodes of your workflow? If i make an HTTP Request just to google in the HTTP Request node I get the HTML output which is expected.

As you are using the HTML Extract node though I wonder if maybe you are using an older version of n8n, Having the nodes or entire workflow json may help show where the issue is though.

Hi Jon,

Thanks for your reactivity, I’ll try to explain more :

  • I have DB with Google Maps Links that I need to scrap
  • If I do an http get on theses links, Google map will blocked me with captcha, cookies etc…
  • I am trying to import manually the cUrl to do an http get with headers, responses etc. When I am trying this cUrl it’s works as well on Insmonia
  • When I do an http get with this cUrl, I have the precedent result with the special caractere.
  • So I tried to transform theses data with move to binary (with the option file on the node http) but i have nothing good.

here is my workflow :

When i changed the encoding in base64 I have something like :


I am running version [email protected]

Hey @hob,

What does the data you are expecting back look like? I am not convinced that it is binary data I have done a quick test with fileinfo and it isn’t detected as a known format. It could be something else on the page that is designed to stop scraping.

I just want to extract the html from a google map page through a node http but I have this result :

I think is just the format in the result that I need to transform in another format…

Hey @hob,

I have just taken another look and it might be the headers you are sending, try this…

1 Like

It’s works, thanks a lot !! It was just the Follow redirect ? Or you changed something else @Jon ?

I removed a couple of headers as well.

Yes I saw that, thanks for your help !

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.