Data Transformation - Trouble with iterator/Split items

I have tried various method and it seems like only one item goes [0] and no further [1], [2].

I have used previously and it worked perfectly by using iterator . I am new to n8n and testing my first module.

Make Screenshot

Note: I do not have much understanding on json/javascript or whatever. At the best I can copy/paste from similar situations/flows.

Hi @hitesh :wave: Welcome to the community :tada:

You mentioned you’ve tried various ways of getting this to work - could you share with us what your n8n workflow looks like? You can do that by heading to the workflow editor for the workflow in question where you’d edit or add nodes, and hitting ctrl/cmd + a and then ctrl/cmd + c. This will copy all the nodes - from there, if you could place it between two sets of three backticks (```), that will share your workflow with us so we can take a look at what you’re doing!

Hi @hitesh


Maybe it is a good idea to start with the n8n courses. As it will give you a feeling of how to tackle things in n8n.
Every node is for example executed for every item/record (except some specific ones)
So it should do what you want automatically. Maybe you need to split the array into items, as it will not have this behaviour if you have an array nested in an object.
But the courses should teach you the basics. :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.