Date & Time node - option to format is gone in 0.217.2!

I upgraded to v 0.217.2. I need to format dates, but the new date & time node does not offer the option to format dates anymore, only to add e substract

Please share the workflow

I tried using an existing node, but it no longer works:

Information on your n8n setup

  • n8n version: 0.217.2
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm,, desktop app]:

Hi @fxholl, tbh I am not sure if this is intentional or not, but based on not seeing any hint in the changelog I reckon it’s not. I’ll raise this as a bug internally.

As a workaround, perhaps you can use a Set node with an expression of {{ $today.minus({days: 7}).toFormat('yyyyMMdd') }}? This should work like the Date & Time node from your screenshot:


Hi @fxholl, I just tried out n8n v0.217.2 and the Format action still appears for me and works as expected:

I was not able to search for it in the sidebar, but once I’ve added the node to the canvas I could select it just fine. This was on a fresh instance using docker run -it --rm -p 5678:5678 -e N8N_DIAGNOSTICS_ENABLED=false n8nio/n8n:0.217.2. Can you confirm how exactly I could reproduce the problem you are having?

New version [email protected] got released which includes the GitHub PR 5904.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.