Disable “Deactivating workflow during import”

Version 0.226, apparently, disabled the feature i’ve made a couple of weeks ago for my syncer: workflow activation based on the workflow name:
“Deactivating workflow during import”.

Can i disable that deactivating and keep active workflows active?

I guess i can modify the script so it calls

n8n update:workflow --id= --active=true

on every workflow i need before starting n8n.

But the fastest solution would be just to disable that deactivation thing.

Actually, i’ll just update the script - probably that would be fast enough.
But probably its nice to have this kind of breaking changes disable-able :slight_smile:

1 Like

Hi @yavetal, I am so sorry you got caught by surprise here. We try to collect breaking changes in this document, but it seems this change was not considered to break things (but fix another problem instead).

1 Like

The change was surprisingly small: instead of setting “active” in the workflow json, I just called

shell.exec(“n8n update:workflow --id=” + workflowId + " --active=" + isActive);

Right after the import. And that’s it actually.
But it was a bit of surprise indeed :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.