Docker SSL invalid

Hi,

I’m using n8n via docker.

It was working fine until I noticed that there was an error regarding the SSL certificate. It worked for months but for some reason it stopped suddenly.

Here is what I get in the traefik log

docker logs root_traefik_1

time="2021-08-07T11:58:33Z" level=info msg="Configuration loaded from flags."

time="2021-08-07T11:58:35Z" level=error msg="Error renewing certificate from LE: {domainhere.app []}, acme: error: 429 :: POST :: https://acme-v02.api.letsencrypt.org/acme/new-order :: urn:ietf:params:acme:error:rateLimited :: Error creating new order :: too many failed authorizations recently: see https://letsencrypt.org/docs/rate-limits/, url: " providerName=mytlschallenge.acme

I haven’t touched anything at all. So I find it a bit strange… I’ve tried to upgrade n8n but I still get the same SSL error.

I can see that the SSL expired 3 days ago and hasn’t renewed.

Any ideas?

Cheers

Sorry, that issue has nothing to do with n8n rather with traefik and Lets Encrypt. As I do not have much experience with either I can sadly not be of much help here. Anyway, it looks like it tries to renew the certificate but because of some kind of rate limiting could it not do that.

Did you read the documentation page that they linked?

That gives you maybe an idea of what the problem could be.

Thanks @jan

yes I’m aware of Let’s Encrypt rates, however I don’t understand why it didn’t work and reached the rate limit…
Do you know how I can manually renew the certificate with traefik / docker / n8n?
Or is there a way to somehow reinstall n8n / traefik to make it work without losing my data?
Cheers

Sadly do not understand either why it does not work.

It should renew the license automatically before it expires and also tries to do so on startup. That is also apparently exactly what happens and that is why you see this error message. It tries to create a new certificate but it does not work for that rate limit reason.

Yes, you can delete the whole setup without a problem. You just have to make sure that you keep the data of the .n8n folder as that is where all the data is saved (database file if you use SQLite and also the encryption password).

Hey @scouech!

I faced a similar issue with the rate limits. I killed the Docker containers and tried deploying them again after an hour or so. This worked for me as I was not making requests against the rate limits anymore.

Let us know if you’re still facing this issue :slight_smile:

Hey @scouech,

Did you get it working?

@harshil1712 my saviour! I turned docker off. Turned cloudflare off. Waiting 2 hours, restarted docker and it works! Very weird tho, but at least now I can use the service :slight_smile: Thank you!

That’s great! The limit with Let’s Encrypt is a bit annoying but necessary as well. Anyways, I am glad you’re now able to use n8n!

Have fun!