Docker tag 1.0.2 and then latest

im trying the 1.0.2 tag, when can I swap over to latest to get the 1.x thread ?

also when trying to load 1.0.2 docker I get the error on boot.

Error: command /bin/sh not found in the logs, any ideas?

why is it not seeing any shells? how odd

It will be tagged as latest once we deem it stable and officially release it. That will probably be next week.

Regarding your error. So n8n does not start? How are you starting n8n exactly. Please provide as much information as possible. Thanks!

I use portainer on Synology NAS. I use docker compose and set up a stack. Been using this setup since I started using n8n years ago, and it auto updated on latest tag.

here is my docker-compose

version: '3.3'

    image: postgres:latest
    restart: always
      - POSTGRES_PASSWORD=xxxxxxxxxxxxx
      - POSTGRES_DB=xxxxxxxxxxxxxx
      - PGDATA=/var/lib/postgresql/data/pgdata
      - /xxx/xxx/postgres15:/var/lib/postgresql/data

    image: n8nio/n8n:latest
    restart: always
      - DB_TYPE=postgresdb
      - DB_POSTGRESDB_HOST=postgres
      - DB_POSTGRESDB_DATABASE=xxxxxxxxxxx
      - DB_POSTGRESDB_USER=xxxxxxxxxxxx
      - DB_POSTGRESDB_PASSWORD=xxxxxxxxxxxxxxx
      - PUID=xxxxxx
      - PGID=xxxxxxx
      - WEBHOOK_URL=https://xxxxxxxxxxx
      - N8N_PAYLOAD_SIZE_MAX=500
      - TZ=Europe/London
      - GENERIC_TIMEZONE=Europe/London
      - N8N_PROTOCOL=http
      - N8N_ENCRYPTION_KEY=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
      - NODE_FUNCTION_ALLOW_EXTERNAL=request-promise-native
      - 5679:5678
      - postgres
      - /xxx/xxx/n8n:/home/node/.n8n
      - /xxx/xxx/n8n/FILES:/files
    # Wait 5 seconds to start n8n to make sure that PostgreSQL is ready
    # when n8n tries to connect to it
    command: /bin/sh -c "sleep 5; n8n start"

This works fine, until I ask it to use the 1.0.2 tag.

Then I get

 Error: command /bin/sh not found

tried other shells, none of them work either.

switch it back to latest, all works ok again

Hey @RedPacketSec,

I am just updating my portainer install from 1.0.1 to 1.0.2 to see if I get the same issue… Will be back shortly.

Update: For me it is working, When I first updated to 1.0 though I did have to make some changes in Portainer with the user being used. Under the advanced container options make sure you have…

Entrypoint: tini,--,/
Working Dir: /home/node
User: node

I also leave the command on mine empty / default as it isn’t really needed, In theory I can’t think of why this would help but it is worth checking as I had some issues getting my install working which has been fine for a couple of years.

1 Like

im doing mine via the docker compose editor as im doing it as a stack. is your user=node a env variable?

ok well i ran this and removed the command from the bottom of the docker-compose file

docker run --rm -it --user root -v /xxx/xxx/N8N:/home/node/.n8n --entrypoint chown n8nio/n8n:1.0.2 -R node:node /home/node/.n8n

now waiting for this cleanup I assume to finish

query is slow: DELETE FROM "public"."execution_entity" WHERE "id" IN ($1, $2, $3, $4, $5, $6, $7, $8, $9, $10, $11, $12, $13, $14, $15, $16, $17, $18, $19, $20, $21, $22, $23, $24, $25, $26, $27, $28, $29, $30, $31, $32, $33, $34, $35, $36, $37, $38, $39, $40, $41, $42, $43, $44, $45, $46, $47, $48, $49, $50, $51, $52, $53, $54, $55, $56, $57, $58, $59, $60, $61, $62, $63, $64, $65, $66, $67, $68, $69, $70, $71, $72, $73, $74, $75, $76, $77, $78, $79, $80, $81, $82, $83, $84, $85, $86, $87, $88, $89, $90, $91, $92, $93, $94, $95, $96, $97, $98, $99, $100) -- PARAMETERS: ["62546","54233","3986","40044","43156","3984","3983","3987","3981","46849","62550","40045","41610","43157","4001","44669","3980","4129","46850","52063","56520","58865","44667","52062","56522","56523","48500","48499","62552","44668","52061","50338","306","164","40049","41611","43159","41612","43162","44673","14599","44672","48505","512","34761","41613","43163","46854","48506","56526","6938","6925","3877","54238","4495","41614","43164","46855","56528","54241","62557","54240","48509","48508","43165","40052","40053","44676","41616","50342","41621","43168","40054","46860","41618","43169","6945","5053","4674","8103","62559","50344","44684","41619","43170","62554","40069","54244","46862","46861","46863","56533","40060","40065","56534","40058","40066","40068","41620","43171"]```
1 Like

I’m having the same issue. Can’t start directly into a shell, which means I can’t start up a worker.

n8n-10-n8n-worker-1       |  ›   Error: command /bin/sh not found
docker run -it /bin/sh
 ›   Error: command /bin/sh not found

Interestingly once my main n8n container has started up I can exec into that with /bin/sh

i removed the command: from the docker-compose just going to keep it at 1.0.2 until latest tag catches up

1 Like

@SomeGen are you also using portainer?

I just did a quick test from my 1.0.2 install and I am able to access a shell with no issue.


Oddly though using the docker run command does show a command not found error, Let me check some things…

@SomeGen Alright I have some answers…

For queue mode you no longer need to specify n8n first we assume that is what you are going to use so you can just run docker run -it worker and it will start it up.

@RedPacketSec your issue is likely to be caused by this as well, Rather than using the command to wait for the database I would instead use the Docker health check options. We have an example of this here: which might help.


ah, nice never knew that, learn some each time. cool will implement that I think.

1 Like

No, I’m using a docker-compose file. I’ll update my compose file and try with the new syntax.


1 Like

@Jon Awesome thank you, that’s fixed that up nicely.

I’ve updated the worker service in my docker-compose.yml.

    <<: *shared
    command: worker
      - n8n
n8n-10-n8n-worker-1  | n8n worker is now ready
n8n-10-n8n-worker-1  |  * Version: 1.0.2
n8n-10-n8n-worker-1  |  * Concurrency: 10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.