Editor does not show executions correctly

I often can’t see some workflow executions before other executions finish, as you can see in the video below.

Note that they appear and some quickly and even if I manage to get the execution id and put it in the browser’s URL, it still switches to another execution and does not display what I want to see.

I believe this is also linked to the same bug, I want to create a filter to show executions at a time, notice that I choose 13:00 and it filters 16:00 which is the difference from my time zone UTC -03

I don’t know how, but I believe these bugs are connected to the one in the link below

Information on your n8n setup

  • **n8n version:1.24.1
  • **Database (default: SQLite):Postgres 14
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):QUEUE
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):Docker

I tried to recreate but couldn’t. i’m on your same version also on docker.

Did you look at your logs?

Please try to get the logs and post them, that will help tracking down the issue

1 Like

Do you need the editor, webhook or worker log? Or everyone?

@admdiegolima everything you’re able to give