Editor gets stuck on Fetch Test Event / Listen for Event (Telegram, Google Sheets)

Describe the problem/error/question

  1. When I create a new workflow, or testing an existing one in Editor mode, and execute a trigger, nothing happens, GUI just shows “Fetching event” or “Listening for test event” loader screen.

  2. When I close the trigger node, I can’t stop the execution - it is stuck in the “Waiting for Trigger Event” state. I have to exit the workflow and open again. This particular GUI glitch applies to telegram trigger only.

I’ve tried two different triggers - Telegram and Google Sheets, with the same result.
If I save and activate the workflow, I can see events coming though and triggering successful executions - all the while I can’t get an execution to work in the editor mode.


What is the error message (if any)?

Please share your workflow

Share the output returned by the last node

Expected = JSON from telegram
Received = None in Editor Mode GUI, successful executions coming through in “Executions”

Information on your n8n setup

  • n8n version: 1.22.1
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): (not configured… own?)
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Linux Debian-107-buster-64-minimal 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux

n8n Docker Container Configuration Details

  • Docker Image: docker.n8n.io/n8nio/n8n:next
  • Container Name: /n8n_n8n_1
  • Status: Running
  • Port: 5678 (Internal Container Port mapped to Host)
  • Network Mode: n8n_default
  • Restart Policy: Always
  • Volume Mount:
    • Source: /var/lib/docker/volumes/n8n_data/_data
    • Destination in Container: /home/node/.n8n
    • Type: Volume
    • Read/Write: Yes (rw)
  • Environment Variables:

Hey @Fedor_Dragan,

I have just given both nodes a go but I have not been able to reproduce this, If you open the browser dev console when you press on the stop button does it show any errors?

Dear Jon,

I’m receiving delete requests

image
image
image

Here’s a screen capture showing the issue:
https://www.awesomescreenshot.com/video/23869773?key=be3e7f29d66db957b2bd8cb9f740a4ef

It seems like the webhook itself functions properly, but for some reason I can’t have interface react to a test event. Test messages go straight to “executions”, instead of showing up in the node. Same for other external triggers. When I tried the same exact steps on trial-cloud version I had no issue.

This makes creating and debugging workflows very hard. I’d appreciate any pointers.

Thanks,
Fedor

Hey @Fedor_Dragan,

So this sounds like it isn’t an issue with Google Sheets then and is just Telegram. The problem with Telegram is each bot can only have one webhook this is a limition set by telegram that we have no control over.

While your workflow is active the telegram bot will be using the production endpoint, if you want to test a change you would need to disable the workflow then run the test and once you are happy enable it again. This is a bit of a pain and it is why I have multiple Telegram bots for things, I would recommend raising an issue with Telegram to see if they plan to support more than one webhook for each bot.

In the screen caption I’ve shown an issue with the Telegram, however, Google Sheets test event never triggers in the same fashion.

I understand your explanation about one webhook, however, the issue doesn’t go away if I try the suggested actions. The workflow never triggers in Editor, if I try in “inactive” state, or if I try with brand new bots. For comparison, I had a trial version hosted with n8n.io, and everything worked fine, both active and inactive states, in both in Editor mode, and Executions. Stop execution button always stopped the “waiting/listening”.

I’ve tried different browsers, so don’t think this is a browser problem.

I guess I just need to try reinstalling another version. What would be your suggestion?

Hey @Fedor_Dragan,

I don’t think this is a version issue as with Telegram we know it only allows one webhook, On Google Sheets I would need more information to work out what is going on as it works in a different way.

It could be something silly like you don’t have websocket support enabled in your reverse proxy for n8n if you are using one

1 Like