Elasticsearch Node: The resource you are requesting could not be found

Hello, when I want to create a new document using elastic node, I get the following response (Actually all of the API calls seem to fail except for the GET index, I can retrieve the index id, but that’s all):

ERROR: The resource you are requesting could not be found

This is the error message:
404 - {"statusCode":404,"error":"Not Found","message":"Not Found"} - Not Found

I also send 3 attachements, first is the actual request from the node, second is elasticsearch connection and credentials, and third is the elastic cloud index management screen.

I’m using n8n cloud version and elastic cloud version.

I’m open for any suggestions. Thanks in advance.

Hi @Sabr3, welcome to the community!

I am sorry you’re having trouble. Is there a chance the Elasticsearch URL base URL in your credentials is wrong?

The /app part looks like the URL might be for Kibana, whereas Elasticsearch itself typically wouldn’t be deployed under a separate path, so the URL would just be something along the lines of https://my.elasticsearch.host:port as hinted in the placeholder:


Perhaps you can double-check your Elasticsearch URL?

Yeah, tried that already, the problem is, the n8n won’t even connect using that url.

Which error are you seeing under “More details”? Do you have any kind of IP filtering enabled in your firewall, preventing n8n from talking directly to your Elasticsearch instance?

No IP filtering is enabled, Error is “Not Found”.

I’ve created a trial account for one of Elastic’s SaaS plans following your report, and it seems they use a different URL structure to the one in your screenshot.

Can you replace kb in your URL with es? This worked for me:

Fetching document also works as expected:

1 Like

Yep, it’s working now, that I changed the URL. I don’t know why the url contained kb. Anyway thanks for your help.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.