[Error] API POST request with form-data BODY

Hi, I tried to replicate a request made on Postman in n8n and I got the error message
“400 - “{"status":false,"result":"Missing login credentials"}””,

Information on your n8n setup

  • n8n version: Self hosted 0.224.4
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via: Docker
  • Operating system: MacOS

I updated to the last version (0.228.2), but the issue is still present…

Hey @tool_dmvf_ltd,

That is odd the api is saying it is missing but it looks like it is there to me. Have you tried making the same request to something like webhook.site from postman and n8n to see if there is any difference in what is sent?

Hi @Jon , thanks for your reply, but I actually don’t know how webhook.site works :sweat_smile:
I add that I tried to import the postman CURL using the “Import cURL command” function and I think there is a bug, because it only imports the URL and not the form-data

This is the call (you can try):

curl --location 'https://api.domain.com/xxxxxxx/' \
--form 'user="xxxxx"' \
--form 'password="xxxxxxxxxxxxxxxxxxxxx"' \
--form 'from="2023-05-15"' \
--form 'to="2023-06-03"'

Can you check please?

Hey @tool_dmvf_ltd,

I have just given a quick test against webhook.site from Postman and n8n using the same values and it looks ok to me. If you replace the expression with fixed values does it work? Can you also share the full workflow so I can see if there is anything odd?

Hi @Jon you can close this post… It was an error server side. Sorry

1 Like

Thanks for the update :raised_hands:

1 Like