Describe the problem/error/question

Getting ERROR: connect ETIMEDOUT on postgres node when workflow runs on set cron timings

Screenshot 2023-06-01 at 1.32.58 AM

What is the error message (if any)?

Error: connect ETIMEDOUT
    at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1278:16)
    at TCPConnectWrap.callbackTrampoline (node:internal/async_hooks:130:17)

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.226.2
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud
  • Operating system: Mac OS

Hey @Paddy_Pohare,

It looks like a network timeout, There was an incident on Azure yesterday around networking so it could be that you ran into that.

Are you still seeing this issue now?

Hello @Jon
Yes we are still facing same issue.
Today all of our workflow failed and we are getting same error
We even tried manually running the postgres node, but getting same issue
Error: connect ETIMEDOUT

Hey @Paddy_Pohare,

On your database do you have the IPs in an allow list? It could be that the IP has changed for your instance and the list needs to be updated.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.