Error connecting to self-hosted NocoDB

Hi all,

I have and self-hosted NocoDB and it’s working correctly.

But when I try to connect from N8N, i receive that error.

I’m connecting via HTTP, not secure.

Anyone knows why happen?

NodeApiError: UNKNOWN ERROR - check the detailed error for more information
at Object.requestWithAuthentication (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/NodeExecuteFunctions.js:1020:19)
at processTicksAndRejections (node:internal/process/task_queues:96:5)
at Object.apiRequestAllItems (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/NocoDB/GenericFunctions.js:39:24)
at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/NocoDB/NocoDB.node.js:360:44)
at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:659:28)
at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:585:53

Thanks you
Regards

Hey @sistemes, this sounds like a network problem on your side. How are you running n8n and NocoDB? Are they both on the same network?

Hi @MutedJam,

Yes, I think is a network problem.

N8N is configured in a Docker container with Traefik.
NocoDB is also in a Docker container.
Both are in the same server.

I tried to connect via API with NocoDB from an external machine and from the same machine via cURL and it’s work properly.

But, if I try to do a cURL from the N8N docker container, it fails,

It seems a network problem between the dockers, but I’m a newbie with Docker and now I’m trying to set the networks.

Thanks you
Regards

I fixed the network problem, and now both Dockers can connect.

I created a new Docker network, and then I assignated it to both containers, so then they are in the same network and can connect.

Solved!

Glad to hear you manage to sort it, thank you so much for confirming and sorry it took me a while to reply here. My main tasks are keeping me really busy these days :frowning: