Error connecting to WooCommerce

Hello,

i am trying to connect my WooCommerce Account.

I followed all the steps described in the Doc: WooCommerce credentials | n8n Docs

but its not working. I get the following error:

Couldn’t connect with these settings 
Request failed with status code 401

All entries are 100% correct.

Does anyone has an idea, what the problem is?

Thanks

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @JanniMcFlurry,

Welcome to the community :raised_hands:

A 401 error code typically means the authentication has failed which would point to the details not being correct, Which version of WooCommerce are you currently using?

1 Like

WooCommerce Version: 8.3.0

But the input is 100% correct.

Do i have to make any settings within WooCommerce?

Hey @JanniMcFlurry,

Assuming it has read / write permissions when you create the token it should be all good. Can you try setting the Include Credentials in Query box to see if that makes any difference? Do you also have any other Wordpress plugins installed that may change the urls for things like some of the security plugins?

Where do you have WooCommerce hosted as well, I have had issues in the past with servers running on Ionos.

1 Like

Hello, Estou com o mesmo problema. I’m trying to connect my WooCommerce Account. I followed all the steps described in the Doc: WooCommerce credentials | n8n Docs 1 .
But its not working, get the following error:
Couldn’t connect with these settings
Request failed with status code 401

All entries are 100% correct.
Woocommerce: 8.4.0
n8n: 1.21.1
running n8n in Digital Ocean
Does anyone has an idea, what the problem is?
Thanks

Hi @ThiagoFPereira, @JanniMcFlurry

You have to enable “Include Credentials in Query”. Then it will work. I’ve tested it on my WooCommerce Credentials. Without this Setting enabled → Error 401. Enabled → Connection working:


2 Likes

thank you very much!!!
It worked here!!!
Have a good week and thanks again

1 Like