Error connection to google sheets node

Hi there,

I ve got an error to connect the google sheets node through OAuth2 API while I ve got no issue for connecting google drive node. I tried with 3 different emails address (with and without workspace) but always same answer from google : “this app has been blocked”

Can anybody help me to solve the problem ?

Many tks in advance

1 Like

This isn’t an n8n issue, but a Google API permissions issue.

Please re-check the API permissions in your Google API settings: Google - n8n Documentation

Tks for you reply. I agree with you but not sure I can resolve the problem without subscribing for a google service account as I don’t see where to fix this issue with OAuth2 single. Am I right ? If anybody can help me with the settings I would be very grateful. regards

Hi @Aurelien,

As you are using Cloud I would try and make a new credential and see if that fixes the issue.

1 Like

Same, here

Hey @Ben_Debonne,

This is currently a known issue with cloud, if you drop in an email we can go over the process with you to work around it.

Hi Jon, Tks a lot for reply, what do you mean by Cloud ? sorry for my ignorance

I tried 2 other credentials but same results…

Are you using n8n cloud @Aurelien? Or in other words, do you use n8n on a domain ending with n8n.cloud? If so, you are probably affected by the problem documented on n8n.cloud status

If you reach out to [email protected], we can apply the workaround for you. This will mean we temporarily remove the existing Google Sheets OAuth2 details from your cloud instance. You would have to manually set up your OAuth2 client as described on Google: OAuth2 single service - n8n Documentation.

Just reach out if this is would be helpful for you and sorry for the trouble this causes.