ERROR: could not read Username for '': terminal prompts disabled

Describe the issue/error/question

I can’t use git pull as a action in my workflow.

What is the error message (if any)?

ERROR: could not read Username for '': terminal prompts disabled

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.216.0
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm,, desktop app]: Docker

Hey @Yummi_Donut, welcome to the community. Have you tried disabling the Github trigger or the manual trigger once? Sometimes the workflow doesn’t know where to start and takes the wrong path :flushed:. Otherwise: Is your username setup properly?

I tried disconnecting both triggers.
And the username + accestoken were set through git credentials in n8n

Hey @Yummi_Donut,

That error is coming back from Github, You need to set the git config options for the username and if it is a private repo you will also need to add the SSH key to your docker instance so it can be read from the git node.

The git node uses the git cli behind the scenes so it would be the same options you would normally need from a desktop when using it.

And if I don’t use SSH Keys on my git repo? Normally I user my github username and a github acces token to pull/push stuff.

Hey @Yummi_Donut,

I am not sure what the git command line option would be for that. It is designed to be non interactive, the general advice I can find online recommends using ssh keys and I can’t see anything for passwords.

Ok, I got my SSK key, how can I add this to my docker instance?

Hi Yummi,

I would try mapping it as a volume to your container like you normally would to add files to any container then once set it should be a case of setting the git config item although you could try adding the key to the users home directory in the container which would be something like /home/node/.ssh/

Still didn’t get it working
I generated a github ssh key that was saved in /root/.ssh/ and I mapped it into /root/.n8n/.ssh inside the docker container. But I get the same error.

n8n does normally not run as root inside of Docker, rather as node. For that reason please try /home/node/.ssh/ as suggested by @Jon .

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.