ERROR:Credentials could not be decrypted. The likely reason is that a different "encryptionKey" was used to encrypt the data

i am running self hosted n8n on unraid and suddenly today,

some of my existing workflow is facing this error. It happens on nextcloud node, google sheet node and seatable node. I tried renewing my seatable api , and it is showing the same error

and i am running the following version.

The error message actually describes exactly what the problem is. The “encryptionKey” must have changed. To be more exact, did you either not persist the ~/.n8n folder or the file ~/.n8n/config (in which the key is stored) got deleted.

In case you did set the encryptionKey via the environment variable N8N_ENCRYPTION_KEY, then the value of that variable must have changed.

There is sadly no way of getting the data back without the original key (after all, is exactly that the reason for having it). What you have to do, is to make sure that in the future the encryptionKey does get persistent and does not change again. Then delete all existing credentials and recreate them again.

Sorry, there is sadly nothing else that can be done.

Not sure how you run n8n but I advice you follow our Server Setup Guide to make sure that n8n is setup correctly.

Hello @jan thank you for guiding on how to solve the problem. I will take a look at what happens to my setup… :grinning:

Great to hear that it was helpful!

Good luck with finding what went wrong in your setup.