Error: Dropbox OAuth Credentials

Hi, i’m receiving an error when trying to add Dropbox OAuth credentials.

I have followed the procedure of OAuth as described here:

The dropbox app has been given all the permissions.


Kindly advise how to rectify this.

Hey @shrey-42!

I encountered a similar issue a few days back, but I wasn’t sure if it was me. For now, you can use the Access Token credentials to authenticate. If you still want to use OAuth, let me know. I have found a workaround that might work, but I refrain from using it.

Hi @harshil1712, yeah, for now i’ll keep using the Token based auth.
Do let me know if a permanent fix for OAuth comes around.

Definitely. I have informed the team and hopefully it will get fixed soon. I will post here once it is fixed :slightly_smiling_face:

1 Like

mmm seems like an update on the dropbox side, now we have to update the scopes we are asking the users for.

Got fixed with [email protected]

1 Like

@jan, unfortunately, this is still not working. I am receiving the exact same error as earlier.

my n8n version: 0.99.1

Hey @shrey-42!

Can you try re-creating the credentials and configure them with n8n? It is working fine for me.

I did. I even tried creating a new app in Dropbox.
This is the latest error:


Can you tell me how are you running n8n? This however seems to be an issue with Dropbox, and not n8n.

Docker container with PostgresDB, hosted in a DO Droplet

This seems be an issue with your Dropbox app. I would suggest you to reach out to the Dropbox folks.

@shrey-42 can also confirm that. Did test it 1-2 days ago. All working perfectly now.

And looking at the error you are getting is actually not exactly the same at all. More a totally different one. So would really Google the error or contact Dropbox. This is one page I found which talks about what could cause this issue:

@harshil1712 @jan

Thanks for the feedback.

Could you also confirm if the case where it’s working for you guys is with a Dropbox app that’s in Development stage or Production stage?

I have tested with the apps of both the kind. As mentioned earlier, this is not an issue with n8n. This is an issue with Dropbox, and I don’t have enough knowledge on that :frowning:

If you can reach out to the Dropbox team, they should be able to help you :slightly_smiling_face: