Error Getaddrinfo EAI_AGAIN n8n on a Synology NAS

Hello n8n community!

I am new to n8n, I have to say… I installed it on my Synology NAS with a Docker. Everything installed find but when I’m trying to execute the node I get always same error message:

ERROR: UNKNOWN ERROR - check the detailed error for more information
getaddrinfo EAI_AGAIN api. notion .com

« status »: « rejected »,

« reason »: {
« message »: « getaddrinfo EAI_AGAIN api.notion. com »,

« name »: « Error »,

« stack »: « Error: getaddrinfo EAI_AGAIN api .notion. com at GetAddrInfoReqWrap.onlookup [as >oncomplete] (node:dns:71:26) »,

« code »: « EAI_AGAIN »



Here it was with the workflow I was trying to implement with Notion, but it happens also with simple http request where no credential is required.

Would someone have an idea?

n8n version: 0.169.0
Installed on NAS Synology
Docker: 20.10.3-1239

Hi @Philippe, welcome to the community and I am very sorry to hear you’re having trouble here.

EAI_AGAIN isn’t an n8n-specific error but suggests network problems (specifically, resolving the domain name seems to fail here). Is there any chance your NAS system restricts DNS lookups from docker containers or other network traffic for whatever reason? Or could this have been a temporary problem with the name resolution in your network?

Hello @MutedJam and many thanks for your warm welcome and swift answer!

Thanks for putting me ontrack! Indeed this must be due to bad setup in the docker, it’s a good start for me. The only thing I found out is that setting up a docker is much more complex than what I was expecting!
I have tried to look at tutorials, but nothing specific on n8n unfortunately for me and I am still stuck on it.
Could someone who experienced the installation of n8n on a NAS Synology just give me some main directions to look at ?
It would be really great, thanks a lot in advance!

I don’t think we have any Synology users internally (I used to have a QNAP NAS, but that’s gone now) unfortunately, but perhaps a fellow community member will be able to help with this.

Is this specific to the Notion node or are you also running into trouble when pulling data from other sources? An easy way to test this would be the HTTP Request node, for example something like this:


Just to keep you updated on my issue that I solved.
I had not setup correctly my domain within Docker, hence the issues I was getting.
Now it is solved, I can send some http requests.

Thanks anyway again!