"Error: getaddrinfo EAI_AGAIN

Hello!

**I keep getting this error everytime I try to set up a node. I have tried so far Invoice Ninja and Trello and I get the same error messages (error pasted below). **

Having investigated the error in Google, I see that it is a DNS issue. I have been reading https://docs.n8n.io/reference/server-setup.html#_3-install-docker-compose and I see a section for DNS SETUP for Docker but I don’t understand where I need to add the A record.


#4. Setup DNS

Add A record to route the subdomain accordingly.

Type: A
Name: n8n (or whatever the subdomain should be)
IP address: <IP_OF_YOUR_SERVER>

So, if anyone could point in me in the right direction, I would be much obliged.

Results: 1

ERROR: Error: getaddrinfo EAI_AGAIN invoiceninja.lucion.guru

RequestError: Error: getaddrinfo EAI_AGAIN invoiceninja.lucion.guru
    at new RequestError (/usr/local/lib/node_modules/n8n/node_modules/request-promise-core/lib/errors.js:14:15)
    at Request.plumbing.callback (/usr/local/lib/node_modules/n8n/node_modules/request-promise-core/lib/plumbing.js:87:29)
    at Request.RP$callback [as _callback] (/usr/local/lib/node_modules/n8n/node_modules/request-promise-core/lib/plumbing.js:46:31)
    at self.callback (/usr/local/lib/node_modules/n8n/node_modules/request/request.js:185:22)
    at Request.emit (events.js:310:20)
    at Request.onRequestError (/usr/local/lib/node_modules/n8n/node_modules/request/request.js:877:8)
    at ClientRequest.emit (events.js:310:20)
    at Socket.socketErrorListener (_http_client.js:426:9)
    at Socket.emit (events.js:310:20)
    at emitErrorNT (internal/streams/destroy.js:92:8)

We used docker to install n8n.io and it runs… I just have that error message.

Having looked in the file.directory, we are seeing that the folders that the error message specifies dont appear in the server. So wondering if there was an error installing with docker… however, now I have seen a lot of errors with node.js and cpanel.

Has anyone who has used cpanel overcome this issue? I’m using a vps on hostgator.

We initially tried to use cli but couldnt get the installation to run.

Those DNS settings are totally unrelated.

The DNS setting in the setup is for incoming connections. There you tell the world how to find your n8n instance. So if somebody calls n8n.example.com they get the IP address of your server back.
If your n8n instance is running already and you can reach it (which you apparently can as you get this error message when you run a node), then this is set up correctly.

The problem you are having is the other direction, outgoing. n8n can for some reason not find the IP address of the service you want to connect to. This is however not directly a problem with n8n, more on a lower level. Very likely it is something like a firewall or something else that blocks those requests. So best to google for possible solutions.

Thanks @jan

I’m assuming it has something to with the server, we mounted n8n.io on a laptop and were able to successfully achieve the node execution with the same credentials for Invoice Ninja… so it works. Just need to figure out why it is not working on hostgator/cpanel.

When we do the npm install, it fails on certain files. Having done some googling, I see that cpanel and node.js have issues. I found this https://docs.cpanel.net/knowledge-base/web-services/how-to-install-a-node.js-application/ so we will be trying our hand at this later today to see if it works.

Docker was the only way we got it to install on the server but clearly something isn’t right.

Will also look at the fire wall issue that you mention.