ERROR: Got timeout reading communication packets In MySQL Node

My workflow has worked fine until recently. I started getting “ERROR: connect ETIMEDOUT”.

So I increased the timeout in the credential settings.
Now I’m constantly getting this error. ERROR: Got timeout reading communication packets

Now I’m stumped at what to do. I’m using an AWS Lightsail Database.

Hey @datdudejibril,

Did you make any changes recently with n8n or the database instance?

It looks like the timeout is on the database side, are there any database logs you can check or settings you can tweak?

Thanks Jon. I enabled “retry on fail” and that seems to have solved the issues…

1 Like